This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 438647 - "About gnome" dialog crash
"About gnome" dialog crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-23 17:42 EDT by Nikos Charonitakis
Modified: 2008-04-29 09:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 09:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sceenshot showing error messages (121.35 KB, image/png)
2008-03-23 17:45 EDT, Nikos Charonitakis
no flags Details
crashes again (156.43 KB, image/png)
2008-04-08 20:07 EDT, Nikos Charonitakis
no flags Details

  None (edit)
Description Nikos Charonitakis 2008-03-23 17:42:03 EDT
Description of problem:
when i press menu->system->about Gnome nothing appears
running gnome-about from command line shows some errors and nothing happens again.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nikos Charonitakis 2008-03-23 17:45:05 EDT
Created attachment 298870 [details]
sceenshot showing error messages

i could only show them through screenshot because keyboard is not working
properly in virt manager so i could connect to my bugzilla account and paste
this text.
Comment 2 Jon Stanley 2008-03-23 23:07:27 EDT
Looks like some sort of internationalization thing maybe, since I can't
reproduce it here in US English.  What language is this?  BTW, I transcribed the
python exception below:

KeyError: u'\u033c\u03bd\u03bf\u03bc\u03b1'

Also, what version of gnome-desktop is this?  I'm running
gnome-desktop-2.22.0-2.fc9.x86_64 here

Comment 3 Nikos Charonitakis 2008-03-24 05:09:13 EDT
Language is Greek -version of gnome-desktop is the latest from rawhide (march 23).
Maybe you are right. I will check gnome-desktop greek translation for any errors.
Comment 4 Nikos Charonitakis 2008-03-24 05:17:14 EDT
Update: greek translation seems is ok.
http://l10n.gnome.org/POT/gnome-desktop.HEAD/gnome-desktop.HEAD.el.po

 msgfmt -cv -o /dev/null gnome-desktop.HEAD.el.po 
69 translated messages.

Comment 5 Simos Xenitellis 2008-03-24 06:11:57 EDT
Apparently it is this message, 

#: ../gnome-about/gnome-about.in:865
msgid "%(name)s: %(value)s"
msgstr "%(όνομα): %(τιμές)"

The correct translation should be

#: ../gnome-about/gnome-about.in:865
msgid "%(name)s: %(value)s"
msgstr "%(name)s: %(value)s"

This might actually give grief to other languages as well.

Am fixing now.
Comment 6 Simos Xenitellis 2008-03-24 06:13:20 EDT
Ok, fixed upstream.

There is also a second occurrence,

#: ../gnome-about/gnome-about.in:920
msgid "<b>%(name)s:</b> %(value)s"
msgstr "<b>%(name)s:</b> %(value)s"
Comment 7 Matthias Clasen 2008-03-26 13:01:41 EDT
Fixed in 2.22.0-3.fc9. Fixed for mk, too.
Comment 8 Nikos Charonitakis 2008-04-08 20:07:31 EDT
Created attachment 301733 [details]
crashes again

another similar error appeared with latest rawhide gnome-desktop package (see
screenshot )
Comment 9 Matthias Clasen 2008-04-09 09:15:25 EDT
Thats unrelated, looks like a cairo dependency issue. Please make sure you have
the latest pixman installed.
Comment 10 Nikos Charonitakis 2008-04-09 15:25:46 EDT
ok updated to latest pixman. Works fine.
Comment 11 Matthias Clasen 2008-04-09 16:37:50 EDT
Behdad, we should probably bump the pixmap dependency in cairo to avoid this.
Comment 12 Keith Pattington 2008-04-24 09:56:18 EDT
Just tried fedora-9-pr-i686 live cd and aformentioned about dialog caused hard
lockup of ui at least, not able to verify any further. Config: english, vesa for
nv on acer core 2 notebook.
Comment 13 Matthias Clasen 2008-04-29 09:45:45 EDT
The cairo -> pixman dependency is correct now, so I am going to close this bug.
If there are further problems with about gnome, please file them against
gnome-desktop.

Note You need to log in before you can comment on or make changes to this bug.