Bug 438689 - firefox is almost unusable
firefox is almost unusable
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 10:43 EDT by Jakub 'Livio' Rusinek
Modified: 2008-03-25 06:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 18:28:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub 'Livio' Rusinek 2008-03-24 10:43:10 EDT
Description of problem:
firefox, built on top of xulrunner is completely unusable, while non-xulrunner
build from ftp.mozilla.org works fine.

Version-Release number of selected component (if applicable):
firefox-3.0-0.45.cvs20080317.fc9

How reproducible:
always

Steps to Reproduce:
1. install firefox from rawhide
2. run (on current profile or on new)
  
Actual results:
* history is not saved
* locationbar doesn't display current address, but typed string (even when tab
opened or closed)
* there's wrong context menu for bookmarks bar (all possible items are visible:
those for rss and for folders too)
* bookmarks doesn't work

Expected results:
everything works as in mozilla's build

Additional info:
works on opensuse (I mean the xulrunner build ofc.)
Comment 1 Jakub 'Livio' Rusinek 2008-03-24 14:47:33 EDT
* resizing search field doesn't work
Comment 2 Jon Stanley 2008-03-24 18:28:25 EDT
Cannot reproduce any of this.  Your version of firefox is old too:

firefox-3.0-0.46.cvs20080320.fc9.x86_64
Comment 3 Jakub 'Livio' Rusinek 2008-03-24 18:44:49 EDT
$ rpm -q firefox
firefox-3.0-0.44.cvs20080315.fc9

$ yum --enable development update firefox
development               100% |=========================| 2.4 kB    00:00     
Setting up Update Process
Could not find update match for firefox
No Packages marked for Update
Comment 4 Jakub 'Livio' Rusinek 2008-03-24 18:56:27 EDT
The newer [taken from koji] won't start.
Backtrace:

#0  0x00404e00 in js_Invoke () from /usr/lib/xulrunner-1.9pre/libmozjs.so
#1  0x00404fe5 in ?? () from /usr/lib/xulrunner-1.9pre/libmozjs.so
#2  0x003d05cf in JS_CallFunctionValue ()
   from /usr/lib/xulrunner-1.9pre/libmozjs.so
#3  0x00687756 in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
#4  0x00e5ebf0 in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
#5  0x00e5efef in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
#6  0x00e5f0c1 in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
#7  0x00e5fe92 in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
#8  0x00e3641d in NS_InitXPCOM3_P () from /usr/lib/xulrunner-1.9pre/libxul.so
#9  0x006423b5 in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
#10 0x0064421e in XRE_main () from /usr/lib/xulrunner-1.9pre/libxul.so
#11 0x08049169 in __gxx_personality_v0 ()
#12 0x00280390 in __libc_start_main () from /lib/libc.so.6
#13 0x08048cc1 in __gxx_personality_v0 ()
Comment 5 Jon Stanley 2008-03-24 20:53:56 EDT
Interesting.  I'm using it right now to write this comment :).  Your locale is
Polish, correct?  I'll install a Polish system and see if I can reproduce.  Mine
is en_US?
Comment 6 Jon Stanley 2008-03-24 22:46:58 EDT
Installed a polish machine and can still do all of the above items.

 * Browser displays correct location (tried a google search and clicked on a
result - address bar showed location of clicked on page)
 * Bookmarks functional (made bookmark, closed browser, opened browser and found
bookmark still there and took me to bookmarked location)
 * exited browser and history still there
Comment 7 Jon Stanley 2008-03-24 22:58:58 EDT
Sorry, X in rawhide went wacky on me before I was done with my previous comment. 

 * Able to resize search box

and obviously since I was able to do all these things I was able to launch it :)

Your yum call to enable the development repo tells me that this is not a fully
rawhide machine.  There may be dependencies on the new version of glibc for
example in rawhide, or maybe some weird Xorg 7.3 stuff that it uses since it was
compiled with it.  But on a fresh rawhide Polish install, everything worked fine
for me.
Comment 8 Jakub 'Livio' Rusinek 2008-03-25 06:15:53 EDT
You're probably right...

Firefox from rawhide never worked on 8 properly.

Epiphany and Yelp worked nice.

Note You need to log in before you can comment on or make changes to this bug.