Bug 438695 - nautilus-sendto missing escaping in the To field
nautilus-sendto missing escaping in the To field
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus-sendto (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 11:13 EDT by Jonathan Blandford
Modified: 2013-04-02 00:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 07:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Blandford 2008-03-24 11:13:13 EDT
Nautilus-sendto is putting the name unquoted in the To field of the mail when
trying to send a file.  For example, if I send one two myself, it will put:

Blandford, Jonathan <jrb@redhat.com>

on the To line.  Because of the comma, this will send mail to "Jonathan
<jrb@redhat.com>" and Blandford@redhat.com, which will bounce.
Comment 1 Bastien Nocera 2008-03-26 07:36:50 EDT
This only happens when you enter an e-mail address with a name, but not using
completion. Fixed upstream.

2008-03-26  Bastien Nocera  <hadess@hadess.net>

        * src/plugins/e-contact-entry.c: Update from SVN and
        fix a warning
        * src/plugins/evolution.c (send_files):
        Quote the e-mail address we pass to evolution, as some
        people might use "Surname, Name <address>" instead of
        just "address"
        (Closes: https://bugzilla.redhat.com/show_bug.cgi?id=438695)

Note You need to log in before you can comment on or make changes to this bug.