Bug 438719 - System Page/Groups Tab shows Hostname heading twice, after using reactivation key
System Page/Groups Tab shows Hostname heading twice, after using reactivation...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Justin Sherrill
Jeff Browning
: Triaged
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-03-24 14:21 EDT by Jeff Weiss
Modified: 2014-11-09 17:47 EST (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of problem (127.87 KB, image/png)
2008-03-24 14:21 EDT, Jeff Weiss
no flags Details

  None (edit)
Description Jeff Weiss 2008-03-24 14:21:39 EDT
Description of problem:
System Page/Groups Tab shows Hostname heading twice, after using reactivation key.

Version-Release number of selected component (if applicable):


How reproducible:
2 for 2

Steps to Reproduce:
1. create a system group
2. kickstart a rhel5 vm
3. create an activation key with the system group you created
4. Get a re-activation key
5. rhnreg_ks with the re-activation key and the activation key you created.
6. Go to the system's page, Groups tab.  See screenshot containing extra headline.
  
Actual results:
Headline with hostname shows up twice

Expected results:
Should only see one headline



Additional info:
Comment 1 Jeff Weiss 2008-03-24 14:21:39 EDT
Created attachment 298915 [details]
screenshot of problem
Comment 2 Jeff Weiss 2008-03-25 10:18:11 EDT
Actually this bug is more of a error handling bug.

As it turns out I accidentally ran step 5 on the vm HOST instead of the GUEST. 
Still, the server should handle this more gracefully.
Comment 3 Jeff Weiss 2008-03-25 10:38:00 EDT
Output matches API doc.  Verified build 179
Comment 4 Jeff Weiss 2008-03-31 13:26:56 EDT
Uh oh, I accidentally marked this bug RP instead of another one.
Comment 6 Justin Sherrill 2009-02-16 11:18:46 EST
Looks like this page is not even in perl any more, and it doesn't look like this issue would apply to the java version.
Comment 7 Jeff Browning 2009-04-27 16:58:44 EDT
Verified. As Justin said, the problematic page is no longer in perl, having been replaced by the Java version.
Comment 8 Miroslav Suchý 2009-08-26 06:03:02 EDT
confirming that the page is in java now. could not reproduce it anymore.

verified in stage on xen5
Comment 9 Brandon Perkins 2009-09-10 16:24:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.