Bug 438728 - Upstream Miro 1.2 released
Upstream Miro 1.2 released
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 14:57 EDT by Jakub 'Livio' Rusinek
Modified: 2008-04-09 01:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.2-1.fc8
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:22:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub 'Livio' Rusinek 2008-03-24 14:57:33 EDT
Description of problem:
miro 1.2 released.
get it while it's hot: http://ftp.osuosl.org/pub/pculture.org/miro/src/

Please notice me in this bug, when Miro 1.2 will reach Rawhide.
Comment 1 Jon Stanley 2008-03-24 23:27:39 EDT
reassigning to version rawhide - sorry for not doing that before
Comment 2 Alex Lancaster 2008-03-25 05:35:15 EDT
OK, rebuilt on koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=43731

should be included in tommorrow's rawhide.  I'd appreciate it if you could
download the RPM and try and manually install it.  According to the blog post:

http://www.getmiro.com/blog/2008/03/announcing-miro-12-a-major-update/

this is supposed to properly support xulrunner 

although the release notes only specifically mentions the xulrunner fix in the
Windows context:

https://develop.participatoryculture.org/trac/democracy/wiki/1.2ReleaseNotes

In any case, I managed to remove most of the xulrunner patch and it still built,
(although setup.py still required patching).  Haven't had a chance to test
myself but hopefully this will move us closer to closing bug #393521.
Comment 3 Dennis Jacobfeuerborn 2008-03-26 00:45:29 EDT
I just tested it and it fails to start with the following output:

[dennis@nexus ~]$ miro
Traceback (most recent call last):
  File "/usr/bin/miro.real", line 135, in <module>
    startapp()
  File "/usr/bin/miro.real", line 95, in startapp
    startup()
  File "/usr/bin/miro.real", line 31, in startup
    from miro.platform.frontends.html.Application import Application
  File
"/usr/lib/python2.5/site-packages/miro/platform/frontends/html/Application.py",
line 33, in <module>
    from miro.frontends.html.main import HTMLApplication
  File "/usr/lib/python2.5/site-packages/miro/frontends/html/main.py", line 40,
in <module>
    from miro.frontends.html import templatedisplay
  File
"/usr/lib/python2.5/site-packages/miro/frontends/html/templatedisplay.py", line
42, in <module>
    from miro.platform.frontends.html.HTMLDisplay import HTMLDisplay
  File
"/usr/lib/python2.5/site-packages/miro/platform/frontends/html/HTMLDisplay.py",
line 37, in <module>
    from miro.platform.MozillaBrowser import MozillaBrowser
ImportError: /usr/lib/python2.5/site-packages/miro/platform/MozillaBrowser.so:
undefined symbol: _ZN12nsCharTraitsIcE12sEmptyBufferE
Comment 4 Alex Lancaster 2008-03-26 01:00:32 EDT
OK apparently the release notes in the blog post:

http://www.getmiro.com/blog/2008/03/announcing-miro-12-a-major-update/

"On Windows and Linux, we updated to XULRunner 1.9, which brings memory and
performance improvements."

is (partially) incorrect.  xulrunner support was only added for Windows, see:

http://bugzilla.pculture.org/show_bug.cgi?id=9499#c10

Unfortunately the Linux xulrunner-related bug (which I originally opened) has
not yet been touched:

http://bugzilla.pculture.org/show_bug.cgi?id=9370

So it builds, but doesn't run.  This isn't really any worse than the previous
1.1.2 which built but wasn't really usable (bug #393521), although that version
didn't crash.  Unfortunately the xulrunner patch that I applied to 1.1.2 doesn't
apply to 1.2.
Comment 5 Jakub 'Livio' Rusinek 2008-03-26 01:48:30 EDT
Alex, they care about Linux like people care about orphaned dogs...

They probably aren't interested in replacing GtkMozEmbed on the left with
appropriate GtkTreeView, which would only make an performance improvement...
Comment 6 Dennis Jacobfeuerborn 2008-03-28 21:10:23 EDT
According to this blog entry there is a snapshot 1.2.2 that runs at least on
Ubuntu with xulrunner 1.9. I tried getting it to work on F9 but failed:

http://pculture.org/devblogs/wguaraldi/2008/03/26/gtkx11-platform-and-xulrunner-19-status/

I got it to compile (some #include directives were missing) but it still doesn't
work properly when started.
Comment 7 Alex Lancaster 2008-03-29 04:45:54 EDT
(In reply to comment #6)
> According to this blog entry there is a snapshot 1.2.2 that runs at least on
> Ubuntu with xulrunner 1.9. I tried getting it to work on F9 but failed:
> 
>
http://pculture.org/devblogs/wguaraldi/2008/03/26/gtkx11-platform-and-xulrunner-19-status/

Thanks!  I'm already on the bug that's mentioned in the blog post:

http://bugzilla.pculture.org/show_bug.cgi?id=9692

but for some reason Will didn't post the blog post on the bug.

> I got it to compile (some #include directives were missing) but it still doesn't
> work properly when started.

Since this bug is really about updating to 1.2, which is already done (about to
push F-7, F-8 builds too) I'm going to change this bug to be for F-8 and it will
close once F-7 and F-8 builds are pushed to updates (stable).

There is already bug #393521 for tracking the xulrunner issues, if you want to
track the xulrunner status, please Cc yourself to that bug.

Comment 8 Fedora Update System 2008-03-29 07:52:23 EDT
Miro-1.2-1.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-03-29 08:35:14 EDT
Miro-1.2-1.fc7 has been submitted as an update for Fedora 7
Comment 10 Fedora Update System 2008-04-01 17:36:05 EDT
Miro-1.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2852
Comment 11 Fedora Update System 2008-04-09 01:11:36 EDT
Miro-1.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-04-09 01:22:28 EDT
Miro-1.2-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.