Bug 438750 - Review Request: qtoctave - fronted for octave written using qt4 widgets
Review Request: qtoctave - fronted for octave written using qt4 widgets
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 16:55 EDT by Claudio Tomasoni
Modified: 2008-11-14 07:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 02:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Claudio Tomasoni 2008-03-24 16:55:37 EDT
Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.1-1.CT.f8.src.rpm
Description: qtoctave is a fronted for octave written using qt4 widgets. It includes a m-editor, a pane for showing variables, a file navigator pane, a command-history pane, lots of helpers to easily create graphics, solve equations, analyze functions, ...

rpmlint output is not clean, but if I try to use the %configure macro or add --libdir to the ./configure line in the spec file, the execution of the configure script fails.
Comment 1 Claudio Tomasoni 2008-03-25 16:59:30 EDT
Updated to cvs 0.7.3
Announce of the availability of the 0.7.3 version is here:
http://qtoctave.wordpress.com/2008/03/25/version-073-in-forge/

qtoctave now uses cmake, so the spec file has been modified to compile with the
new method. Now rpmlint is quiet.

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL:
http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.3-1.139.20080425svn.CT.f8.src.rpm
Comment 2 Claudio Tomasoni 2008-03-26 15:25:46 EDT
Sorry, I forgot to write that this is my first package submission, and in case I
need a sponsor.
Comment 3 Claudio Tomasoni 2008-03-26 19:24:58 EDT
New revision of the spec file, minor changes:
- removed %{vendor} tag from the Release field
- corrections in %changelog, due to previous point
New source rpm with the proper name (my personal tag .CT is no more included)
and not signed.

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL:
http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.3-1.139.20080425svn.fc8.src.rpm

I'm still looking for a reviewer (and a sponsor, of course). Any?
Comment 4 Mamoru TASAKA 2008-04-03 12:27:56 EDT
Rebuild failed at least on i386:
http://koji.fedoraproject.org/koji/taskinfo?taskID=546584
Comment 5 Claudio Tomasoni 2008-04-03 15:25:48 EDT
Fixed silly errors with cmake macro (i wonder why it works at home).

Could you try this update, please?
Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.3-2.fc8.src.rpm
Comment 6 Mamoru TASAKA 2008-04-04 10:38:51 EDT
Still not good.

http://koji.fedoraproject.org/koji/taskinfo?taskID=547875
- For desktop-file-utils usage, please refer to the section
  "desktop-file-install usage" of
  http://fedoraproject.org/wiki/Packaging/Guidelines

- Category 'X-Fedora' is now deprecated and should be removed.

- When using "cp" or "install" commands, add "-p" option to
  keep timestamps on installed files.

- Calling update-desktop-database is not needed because the installed
  desktop file does not contain any MimeType key (ref.
  the section "desktop-database" of
  http://fedoraproject.org/wiki/Packaging/ScriptletSnippets

- About compilation option:
----------------------------------------------------------------------------------
Building CXX object src/CMakeFiles/qtoctave.dir/moc_command_list.o
[ 42%] /usr/bin/c++   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables  -O3 -DNDEBUG -DQT_NO_DEBUG -I/usr/include/QtGui
-I/usr/include/QtXml -I/usr/include/QtCore -I/usr/include/Qt   -DUSER_CONFIG
-DQT_SHARED -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -o
src/CMakeFiles/qtoctave.dir/moc_command_list.o -c
/builddir/build/BUILD/qtoctave-0.7.3/src/moc_command_list.cxx
Building CXX object src/CMakeFiles/qtoctave.dir/moc_codeedit.o
----------------------------------------------------------------------------------
  Here Fedora specific compilation flags uses optimization level -O2,
  which is overrided by later -O3 option and Fedora does not allow this.
Comment 7 Claudio Tomasoni 2008-04-10 15:44:38 EDT
Sorry for the delay, I've been very busy at work...
All notes in the previous comment should be fixed in this release:

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.3-3.fc8.src.rpm

Could you try again, please?
Waiting for new comments...
Comment 8 Mamoru TASAKA 2008-04-12 14:06:27 EDT
Okay, seems good from a very quick check.
I will look closely later.

By the way, as this is NEEDSPONSOR ticket:
-------------------------------------------------------------
NOTE: Before being sponsored:

This package will be accepted with another few work. 
But before I accept this package, someone (I am a candidate) 
must sponsor you.

Once you are sponsored, you have the right to review other 
submitters' review requests and approve the packages formally. 
For this reason, the person who want to be sponsored (like you) 
are required to "show that you have an understanding 
of the process and of the packaging guidelines" as is described
on :
http://fedoraproject.org/wiki/PackageMaintainers/HowToGetSponsored

Usually there are two ways to show this.
A. submit other review requests with enough quality.
B. Do a "pre-review" of other person's review request
   (at the time you are not sponsored, you cannot do
   a formal review)

When you have submitted a new review request or have pre-reviewed other 
person's review request, please write the bug number on this bug report 
so that I can check your comments or review request.

Fedora package collection review requests which are waiting for someone to
review can be checked on:
http://fedoraproject.org/PackageReviewStatus/NEW.html
(NOTE: please don't choose "Merge Review")


Review guidelines are described mainly on:
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines
http://fedoraproject.org/wiki/Packaging/Guidelines
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
------------------------------------------------------------
Comment 9 Mamoru TASAKA 2008-04-14 12:57:29 EDT
Well, for 0.7.3-3:
* Requires
  - "Requires: qt4" is redundant and this should be removed.
    This type of Requires are automatically detected and added to
    rebuilt binary rpms by rpmbuild.

And I will wait for your pre-review or another review request.
Comment 10 Mamoru TASAKA 2008-04-22 11:42:27 EDT
ping?
Comment 11 Claudio Tomasoni 2008-05-03 09:47:05 EDT
Sorry for the big delay (still very annoying troubles at work :-( ).
Here is a new SRPM and a new SPEC file:

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.4-1.fc8.src.rpm

and these are the news:
- updated to 0.7.4
- removed the qt4 explicit requirement
- added a chmod command in the %prep section to fix file permissions oddity
(many .cpp and .h executable files)

I'm looking for a package to pre-review. In the meantime you can take a look to
my other submission:
https://bugzilla.redhat.com/show_bug.cgi?id=439100
Comment 12 Claudio Tomasoni 2008-05-07 18:12:50 EDT
Hi Mamoru,

I've just added a comment (with a new SPEC file and a new SRPM) to the bug
   https://bugzilla.redhat.com/show_bug.cgi?id=439100

and this
   https://bugzilla.redhat.com/show_bug.cgi?id=445604
is another review request for a tiny little game named Tennix!
Comment 13 Mamoru TASAKA 2008-05-08 12:42:53 EDT
2 issues
----------------------------------------------------------
* Thu May 01 2008 Claudio Tomasoni <claudio@claudiotomasoni.it> 0.7.4-1.fc8
----------------------------------------------------------
  - Remove the last ".fc8". This suffix is not valid for non-F9 branches.

  - Would you write a explanation how you got %{name}.png?

Other things seems okay.

Comment 14 Claudio Tomasoni 2008-05-12 18:12:55 EDT
Hi Mamoru,

about last issues:
- removed .fc8 from Changelog
- I took the icon from an icon set downloaded from internet a lot of time ago. I
guess it was freely usable, but since I can't find the original (and thus read
the license), I'm not 100% sure. So, I have drawn a little new icon (a Gauss
curve, made in qtoctave, of course) which is released under GPL and included in
the new revision.

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.4-2.fc8.src.rpm
Comment 15 Mamoru TASAKA 2008-05-13 13:57:23 EDT
For 0.7.4-2:

* %setup
-----------------------------------------
%setup -q
......
tar -xf %{SOURCE1}
-----------------------------------------
  - This can be replaced by
-----------------------------------------
%setup -q -a 1
-----------------------------------------

(In reply to comment #14)
> - So, I have drawn a little new icon (a Gauss
> curve, made in qtoctave, of course) which is released under GPL and included in
> the new revision.
  Much better!!

Well:
- This package is okay (please fix above)
- You have another review request, which is likely to get approved
  soon

-----------------------------------------------------------
      This package (qtoctave) is APPROVED by me
-----------------------------------------------------------

Please follow the procedure written on:
http://fedoraproject.org/wiki/PackageMaintainers/Join
from "Get a Fedora Account".
At a point a mail should be sent to sponsor members which notifies
that you need a sponsor. At the stage, please also write on
this bug for confirmation that you requested for sponsorship and
your FAS (Fedora Account System) name. Then I will sponsor you.

If you want to import this package into Fedora 7/8, you also have
to look at
http://fedoraproject.org/wiki/Infrastructure/UpdatesSystem/Bodhi-info-DRAFT
(after once you rebuilt this package on koji Fedora rebuilding system).

If you have questions, please ask me.
Comment 16 Mamoru TASAKA 2008-05-13 14:07:33 EDT
By the way:

Currently it seems that your srpm does not build on dist-f10:
http://koji.fedoraproject.org/koji/taskinfo?taskID=607415

I don't know cmake well, however cmake maintainer says that
on dist-f10 cmake (2.6.0-1.fc10) is more strict than dist-f9 cmake
(2.4.8-2.fc9) which may be related to this.
Also, dist-f10 qt is 4.4.0, while dist-f9 qt is 4.3.4.
As current rawhide tree is very unstable so I approve this package now,
however please fix this package to get it built.

dist-f9 build is okay:
http://koji.fedoraproject.org/koji/taskinfo?taskID=606402
Comment 17 Mamoru TASAKA 2008-05-20 10:08:29 EDT
ping?
Comment 18 Claudio Tomasoni 2008-05-24 14:53:08 EDT
Fixed the %setup section as indicated:

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.4-3.fc9.src.rpm

I subscribed cvsextras group today and I'm waiting to be approved.

In the meantime I'm going to install Fedora rawhide and take a look at qtoctave
compilation problems.
Comment 19 Mamoru TASAKA 2008-05-24 15:04:35 EDT
Now I am sponsoring you. Please follow "Join" wiki again.
Comment 20 Claudio Tomasoni 2008-06-01 13:18:43 EDT
New Package CVS Request
=======================
Package Name: qtoctave
Short Description: fronted for octave written using qt4 widgets
Owners: claudiotomasoni
Branches: F-7 F-8
InitialCC:
Cvsextras Commits: yes
Comment 21 Kevin Fenzi 2008-06-01 13:28:25 EDT
We are no longer doing F-7 branches. 
Do you really not want t F-9 branch? 
Comment 22 Claudio Tomasoni 2008-06-02 05:27:41 EDT
Oops, sorry! My fault.

New Package CVS Request
=======================
Branches: F-8 F-9

The same for octaviz.
Comment 23 Kevin Fenzi 2008-06-02 11:30:20 EDT
Thanks. 

cvs done.
Comment 24 Mamoru TASAKA 2008-06-12 02:04:45 EDT
Well,

* Please rebuild this package also on dist-f10.
* For F-9/8 packages, please submit a request to push those packages to
  the repositories at
  https://admin.fedoraproject.org/updates/
Comment 25 Claudio Tomasoni 2008-06-22 07:49:47 EDT
Sorry, solved problems with ADSL provider. I'm working on this right now...
Comment 26 Mamoru TASAKA 2008-06-30 12:44:13 EDT
Any updates?
Comment 27 Mamoru TASAKA 2008-07-10 12:46:35 EDT
ping again?
Comment 28 Mamoru TASAKA 2008-07-24 13:06:37 EDT
ping again?
Comment 29 Mamoru TASAKA 2008-08-06 09:57:43 EDT
I will close this bug as NOTABUG if no response is received from the reporter
within ONE WEEK.
Comment 30 Chitlesh GOORAH 2008-08-06 10:20:44 EDT
I'll step in if the reporter is not willing to maintain this package.
Comment 31 Mamoru TASAKA 2008-08-14 10:07:46 EDT
Now regarding the initial reporter as not responding.

To Chitlesh:
If you want to take over the maintainership of this package please resubmit
CVS request (note that this package is already in Fedora CVS) with including
maintainer change request.

If no progress happens with two weeks, I _really_ close this bug.
Comment 32 Claudio Tomasoni 2008-08-24 10:19:27 EDT
I am very sorry for the long absence, but I just stepped out from a very annoying health problem.
If I can still contribute to the project, here is a new version of SPEC and SRPM file that builds in f10 too (the previous versions didn't build):

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.7.5-1.svn20080823.fc9.src.rpm

This package builds in koji for dist-f8, dist-f9 and dist-f10.
Please, let me know if I can still work on this.
Comment 33 Mamoru TASAKA 2008-08-25 03:02:15 EDT
For 0.7.5-1.svn:

* Versioning/Using svn
  - When using svn based tarball, please write as comments how
    you created the tarball:
    https://fedoraproject.org/wiki/Packaging/SourceURL

  - Would you tell me whether the tarball you are using is post- or
    pre- release of version 0.7.5?
    https://fedoraproject.org/wiki/Packaging/NamingGuidelines#Package_Release

  - For svn based tarball, I prefer to use revision number rather than
    the date you checked out.

* build log verboseness
  - Build log output like:
--------------------------------------------------------------
   200  [ 41%] 
   201  Building CXX object src/CMakeFiles/qtoctave.dir/basewidget.o
   202  Building CXX object src/CMakeFiles/qtoctave.dir/codeedit.o
   203  Building CXX object src/CMakeFiles/qtoctave.dir/variables_list.o
   204  Building CXX object src/CMakeFiles/qtoctave.dir/command_list.o
   205  [ 43%] 
--------------------------------------------------------------
    is not useful. For example, we cannot check if Fedora specific compiler
    flags are honored correctly. Please refer to:
    https://fedoraproject.org/wiki/Packaging/cmake#Specfile_Usage

* Icon caching
--------------------------------------------------------------
    47  # desktop file can't find icon
    48  mkdir $RPM_BUILD_ROOT%{_datadir}/pixmaps
    49  mv $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/%{name}.png \
    50     $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png
    51  rm -rf $RPM_BUILD_ROOT%{_datadir}/icons
--------------------------------------------------------------
  - Please refer to
    https://fedoraproject.org/wiki/Packaging/ScriptletSnippets#GTK.2B_icon_cache

Resetting fedora-review flag to question mark.
Comment 34 Claudio Tomasoni 2008-08-25 17:26:29 EDT
Thanks for the comments.
Before pointing to a new SRPM and SPEC file, I've got a couple of questions.

- Would you tell me whether the tarball you are using is post- or pre-
  release of version 0.7.5?
According to the news.txt file this seems to be a post-release of 0.7.5, while according to http://qtoctave.wordpress.com/2008/08/22/qtoctave-081-testing/, and to the help file this version seems to be a pre-release of 0.8.1.
Which adopt?

- For svn based tarball, I prefer to use revision number rather than
  the date you checked out.
So the package should be named 0.8.1-1.svn165 (revision is 165)?

Thanks in advance for your attention.
Comment 35 Mamoru TASAKA 2008-08-25 22:02:10 EDT
According to your comments I guess the current svn should regarded as the
pre-version of 0.8.1 (so EVR must be 0.8.1-0.X.svn165, for example)
Comment 36 Claudio Tomasoni 2008-08-27 16:53:07 EDT
Ok. The new SPEC and SRPM:

Spec URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave.spec
SRPM URL: http://www.claudiotomasoni.it/files/RPMS/qtoctave-0.8.1-0.20080823.svn165.fc9.src.rpm

About https://fedoraproject.org/wiki/Packaging/cmake#Specfile_Usage
Should I insert
   %check
   ctest
even if the result is "No tests were found!!!" ?
Comment 37 Mamoru TASAKA 2008-08-28 10:55:22 EDT
Well, 
* making build.log output verbose
-----------------------------------------------------------------
make iVERBOSE=1 %{?_smp_mflags}
-----------------------------------------------------------------
  - should be:
-----------------------------------------------------------------
make VERBOSE=1 %{?_smp_mflags}
-----------------------------------------------------------------

* %check
(In reply to comment #36)
> Should I insert
>    %check
>    ctest
> even if the result is "No tests were found!!!" ?
  - I don't think this is needed.

Please fix "VERBOSE=1" issue above. As this package is already registered in Fedora CVS
you can import this package without waiting for CVS process.

-----------------------------------------------------------
    This package is re-approved
-----------------------------------------------------------
Comment 38 Fedora Update System 2008-09-02 17:15:47 EDT
qtoctave-0.8.1-0.20080823.svn165.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/qtoctave-0.8.1-0.20080823.svn165.fc9
Comment 39 Fedora Update System 2008-09-02 17:15:53 EDT
qtoctave-0.8.1-0.20080823.svn165.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/qtoctave-0.8.1-0.20080823.svn165.fc8
Comment 40 Claudio Tomasoni 2008-09-03 00:53:17 EDT
Fixed "VERBOSE=1", built in koji and submitted packages as "newpackage" in bodhi for F-8 and F-9.

It's not clear what I should do to have the package in F-10. Should I follow the first section of the howto http://fedoraproject.org/wiki/PackageMaintainers/UpdatingPackageHowTo ?

Many thanks.
Comment 41 Mamoru TASAKA 2008-09-03 02:50:26 EDT
Currently for F-10 packages are automatically pushed if you build the packages
successfully.

Now as I can see you have submitted push requests on bodhi, I close this bug.
Comment 42 Fedora Update System 2008-10-01 02:40:40 EDT
qtoctave-0.8.1-0.20080823.svn165.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 43 Fedora Update System 2008-11-14 07:44:29 EST
qtoctave-0.8.1-0.20080823.svn165.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.