Bug 438786 - kwrite appears in Applications -> Other menu under GNOME
kwrite appears in Applications -> Other menu under GNOME
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-03-25 03:50 EDT by Jens Petersen
Modified: 2008-04-18 13:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 13:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-03-25 03:50:16 EDT
Description of problem:
If one installs kdebase, then kwrite appears in Applications -> Other
on the GNOME desktop.

How reproducible:
every time

Steps to Reproduce:
1. install GNOME and KDE
2. login to GNOME
3. go to Applications menu
  
Actual results:
3. kwrite appears in Other submenu

Expected results:
3. should appear elsewhere I guess (Accessories?)
Comment 1 Jens Petersen 2008-04-14 21:50:22 EDT
Still happening with today's rawhide.

Actually I was pondering if it might be useful to have a mechanism
to separate the KDE menu entries from the GNOME ones
under the GNOME menu - maybe a KDE submenu even?
Comment 2 Kevin Kofler 2008-04-14 21:57:29 EDT
I think this is a horrible idea. IMHO it makes no sense to group applications 
by what toolkit they happen to use, it's almost as nonsensical as the grouping 
by vendor usually used on Window$. Sure, it may seem to make sense for KWrite, 
but what about apps which have no equivalent using the other toolkit?

FYI, kmenu-gnome implements that suggestion the other way round (a GNOME 
submenu in the KDE menu), and I consider the result completely broken and the 
package worthy of an "rpm -e kmenu-gnome" (and nothing else).
Comment 3 Jens Petersen 2008-04-14 22:23:47 EDT
Well I agree partially - but it depends very much on the application.
If I am running GNOME I might not mind having Amarok appearing in
"Sound and Video" say but I would probably prefer to have kwrite hidden
away...
Comment 4 Kevin Kofler 2008-04-14 22:27:37 EDT
The problem is, how do you decide which applications to show in the main menu 
and which under "KDE"? To pick up your own example, I'm sure there are many 
hardcode Rhythmbox/Exaile/Banshee/whatever fans who'll want Amarok banned from 
the main menu too.
Comment 5 Rex Dieter 2008-04-18 13:08:23 EDT
fixed in kdebase-4.0.3-9 (added Categories=+Utility)
Comment 6 Rex Dieter 2008-04-18 13:39:11 EDT
requested f9-final tagging.

Note You need to log in before you can comment on or make changes to this bug.