Bug 438791 - firstboot should not create xorg.conf for Live instances
firstboot should not create xorg.conf for Live instances
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-25 05:27 EDT by Jens Petersen
Modified: 2008-04-04 09:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 12:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-03-25 05:27:32 EDT
Description of problem:
Live instances of Fedora get a xorg.conf generated (presumably
by firstboot?).  Now that we have a persistence option for Live
images on USB it would be better not to create the xorg.conf file
since the persistent image may be booted on a different machine
with different graphics chipset, etc.

Steps to Reproduce:
1. # livecd-tools-iso-to-disk --overlay-size-md 512 ...
2. boot live image on computer A
3. later use live image on computer B with different graphics hardware
  
Actual results:
3. X doesn't start because wrong driver loaded.

Expected results:
3. no xorg.conf file so that it starts on any computer

Additional info:
Workaround is to delete xorg,conf after 2.
Comment 1 Jeremy Katz 2008-03-25 09:34:22 EDT
firstboot doesn't do this, it's the livecd init script.  And there's one or two
things I need to double check with ajax this week before changing this
Comment 2 Jeremy Katz 2008-04-01 12:24:44 EDT
Changed this last week.
Comment 3 Jens Petersen 2008-04-04 05:32:36 EDT
Now it runs system-config-display?
Comment 4 Jeremy Katz 2008-04-04 09:33:06 EDT
The firstboot initscript had changed its logic -- Chris fixed this yesterday
after I finally figured out what was launching it.

Note You need to log in before you can comment on or make changes to this bug.