Bug 438817 - samba timeout problem
samba timeout problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 09:47 EDT by Matt Castelein
Modified: 2008-04-14 10:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 09:33:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
samba configuration file (9.24 KB, text/plain)
2008-03-26 10:05 EDT, Matt Castelein
no flags Details
winbindd.log (165 bytes, text/plain)
2008-03-26 10:05 EDT, Matt Castelein
no flags Details
This machine seems to be able to access the shares (6.48 KB, text/plain)
2008-03-26 10:06 EDT, Matt Castelein
no flags Details
This machine was not able to access any shares or printers (5.91 KB, text/plain)
2008-03-26 10:06 EDT, Matt Castelein
no flags Details
Log file - changed logging level (42.75 KB, text/plain)
2008-03-26 17:43 EDT, Matt Castelein
no flags Details
Log file - changed logging level (12.14 KB, text/plain)
2008-03-26 17:43 EDT, Matt Castelein
no flags Details
Log file - changed logging level (18.16 KB, text/plain)
2008-03-26 17:44 EDT, Matt Castelein
no flags Details
Log file - changed logging level (10.20 KB, text/plain)
2008-03-26 17:44 EDT, Matt Castelein
no flags Details
Log file - changed logging level (7.61 KB, text/plain)
2008-03-26 17:44 EDT, Matt Castelein
no flags Details
smb.conf (1.67 KB, text/plain)
2008-04-06 20:26 EDT, Matt Castelein
no flags Details
Requested test output (14.62 KB, text/plain)
2008-04-14 07:59 EDT, Matt Castelein
no flags Details

  None (edit)
Description Matt Castelein 2008-03-25 09:47:47 EDT
Description of problem:  smbclient and smbtree are not working, timeout
connecting to the local machine;  Shares are working from remote windows
machines as is smb printing.


Version-Release number of selected component (if applicable):
samba-3.0.28a-0.fc8
samba-client-3.0.28a-0.fc8
libsmbclient-3.0.28a-0.fc8
any others?

$ smbtree
Password:
timeout connecting to 192.168.1.4:445
timeout connecting to 192.168.1.4:139
Error connecting to 192.168.1.4 (Operation already in progress)
cli_start_connection: failed to connect to 192.168.1.4<20> (192.168.1.4). Error
NT_STATUS_ACCESS_DENIED
$ smbclient //arturo/mp3
timeout connecting to 192.168.1.4:445
timeout connecting to 192.168.1.4:139
Error connecting to 192.168.1.4 (Operation already in progress)
Connection to arturo failed (Error NT_STATUS_ACCESS_DENIED)
Comment 1 Matt Castelein 2008-03-25 21:53:07 EDT
Ok so I checked again and it seems that as of today I have no access to any
share or printer.  This was recently updated with yum.  My samba users and
shares are all the same as they have always been, everything has just quit
working.  All I get from anywhere now is "access denied"
Comment 2 Matt Castelein 2008-03-25 21:55:32 EDT
My messages file is filled up with this:

Mar 25 21:53:51 arturo winbindd[1928]: [2008/03/25 21:53:51, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Mar 25 21:53:51 arturo winbindd[1928]:   Possible deadlock: Trying to lookup SID
S-1-5-2 with passdb backend
Mar 25 21:53:51 arturo winbindd[1928]: [2008/03/25 21:53:51, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Mar 25 21:53:51 arturo winbindd[1928]:   Possible deadlock: Trying to lookup SID
S-1-5-11 with passdb backend
Mar 25 21:54:01 arturo winbindd[1928]: [2008/03/25 21:54:01, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Mar 25 21:54:01 arturo winbindd[1928]:   Possible deadlock: Trying to lookup SID
S-1-1-0 with passdb backend
Mar 25 21:54:01 arturo winbindd[1928]: [2008/03/25 21:54:01, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Mar 25 21:54:01 arturo winbindd[1928]:   Possible deadlock: Trying to lookup SID
S-1-5-2 with passdb backend
Mar 25 21:54:01 arturo winbindd[1928]: [2008/03/25 21:54:01, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Mar 25 21:54:01 arturo winbindd[1928]:   Possible deadlock: Trying to lookup SID
S-1-5-11 with passdb backend

I'll be out of town until Monday but after that happy to provide any useful data.
Comment 3 Simo Sorce 2008-03-26 09:00:08 EDT
Please attach smb.conf configuration file and log files for winbindd and one of
the machine showing this problem
Comment 4 Matt Castelein 2008-03-26 10:05:28 EDT
Created attachment 299151 [details]
samba configuration file
Comment 5 Matt Castelein 2008-03-26 10:05:50 EDT
Created attachment 299152 [details]
winbindd.log
Comment 6 Matt Castelein 2008-03-26 10:06:27 EDT
Created attachment 299153 [details]
This machine seems to be able to access the shares
Comment 7 Matt Castelein 2008-03-26 10:06:57 EDT
Created attachment 299154 [details]
This machine was not able to access any shares or printers
Comment 8 Simo Sorce 2008-03-26 17:16:34 EDT
The smb.conf looks strange,
for example you have domain master = yes but domain logons is not.

Also please I need log a level 10, so please raise the log level to 10 (log
level = 10 in smb.conf and then try again to connect with a machine. Report log
files.

Also make sure to set back log level to 0 or 1 when you are finished as it may
fill up logs very fast (and slow down you machine considerably).
Comment 9 Matt Castelein 2008-03-26 17:43:24 EDT
Created attachment 299235 [details]
Log file - changed logging level
Comment 10 Matt Castelein 2008-03-26 17:43:48 EDT
Created attachment 299236 [details]
Log file - changed logging level
Comment 11 Matt Castelein 2008-03-26 17:44:07 EDT
Created attachment 299237 [details]
Log file - changed logging level
Comment 12 Matt Castelein 2008-03-26 17:44:24 EDT
Created attachment 299238 [details]
Log file - changed logging level
Comment 13 Matt Castelein 2008-03-26 17:44:54 EDT
Created attachment 299239 [details]
Log file - changed logging level
Comment 14 Matt Castelein 2008-03-26 17:45:45 EDT
I have attached all the log files that changed with the new logging level, and
attempted access.
Comment 15 Matt Castelein 2008-04-06 20:16:38 EDT
Samba is still not functioning, is there any progress here?  Is there any
additional information I can provide to help?
Comment 16 Matt Castelein 2008-04-06 20:17:59 EDT
I have re-done my smb.conf yet still getting the same issues.  Attaching the new
file.
Comment 17 Matt Castelein 2008-04-06 20:26:17 EDT
Created attachment 301451 [details]
smb.conf
Comment 18 Matt Castelein 2008-04-13 21:10:58 EDT
[root@arturo test]# smbclient //arturo/print\$ -U'uuuu%pppp'
timeout connecting to 192.168.1.4:445
timeout connecting to 192.168.1.4:139
Error connecting to 192.168.1.4 (Operation already in progress)
Connection to arturo failed (Error NT_STATUS_ACCESS_DENIED)

Yeah, this still isn't working.  Any news?
Comment 19 Matt Castelein 2008-04-13 21:23:45 EDT
rpcclient -Uuuuu%pppp -c 'adddriver "Windows NT x86" \
"HP DeskJet 1200C/PS:PSCRIPT5.DLL: \
HP1200C1.PPD:PS5UI.DLL:PSCRIPT.HLP: \
NULL:RAW:PSCRIPT.NTF' arturo
timeout connecting to 192.168.1.4:445
timeout connecting to 192.168.1.4:139
Error connecting to 192.168.1.4 (Operation already in progress)
cli_start_connection: failed to connect to ARTURO<20> (192.168.1.4). Error
NT_STATUS_ACCESS_DENIED
Cannot connect to server.  Error was NT_STATUS_ACCESS_DENIED

I would love so much if this worked the way it should.
Comment 20 Simo Sorce 2008-04-14 03:30:35 EDT
Can you provide me the output of the following commands?
/sbin/ifconfig
/sbin/iptables -L -v --line-numbers
testparm -v
Comment 21 Matt Castelein 2008-04-14 07:59:09 EDT
Created attachment 302330 [details]
Requested test output

Minor edits made to this file for security - If there is a problem, let me
know.
Comment 22 Simo Sorce 2008-04-14 08:20:28 EDT
I can't be sure because your iptables actually resolved names or something, but
can you remove your iptables configuration and see if the problem keeps happening ?
It seem to me you are missing to accept any packaet coming in from the lo
interface, and that would explain the timeouts you see as in the Block table,
unfortunately you have a DROP rule and not a more correct REJECT rule.
Comment 23 Matt Castelein 2008-04-14 09:33:46 EDT
I'll be damned, changing the first rule from accepting from 127.0.0.1 to accept
from interface lo brings back my smbtree.  Did something change in the way samba
handles this network access?  I'm still getting a log full of:
Apr 14 09:32:35 arturo winbindd[18645]: [2008/04/14 09:32:35, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Apr 14 09:32:35 arturo winbindd[18645]:   Possible deadlock: Trying to lookup
SID S-1-5-2 with passdb backend
Apr 14 09:32:35 arturo winbindd[18645]: [2008/04/14 09:32:35, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Apr 14 09:32:35 arturo winbindd[18645]:   Possible deadlock: Trying to lookup
SID S-1-5-11 with passdb backend
Apr 14 09:32:45 arturo winbindd[18645]: [2008/04/14 09:32:45, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Apr 14 09:32:45 arturo winbindd[18645]:   Possible deadlock: Trying to lookup
SID S-1-1-0 with passdb backend
Apr 14 09:32:45 arturo winbindd[18645]: [2008/04/14 09:32:45, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Apr 14 09:32:45 arturo winbindd[18645]:   Possible deadlock: Trying to lookup
SID S-1-5-2 with passdb backend
Apr 14 09:32:45 arturo winbindd[18645]: [2008/04/14 09:32:45, 0]
nsswitch/winbindd_passdb.c:sid_to_name(130)
Apr 14 09:32:45 arturo winbindd[18645]:   Possible deadlock: Trying to lookup
SID S-1-5-11 with passdb backend

I guess that must be a separate issue?
Comment 24 Simo Sorce 2008-04-14 10:17:00 EDT
Different problem, see #441499.
Closing this one as it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.