Bug 438822 - Segfault when trying to resize existing partition
Segfault when trying to resize existing partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntfsprogs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 10:06 EDT by Luke Macken
Modified: 2016-09-19 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 13:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2008-03-25 10:06:30 EDT
Description of problem:

[root@localhost fedora]# gdb /usr/sbin/ntfsresize 
(gdb) r -i /dev/sda1
Starting program: /usr/sbin/ntfsresize -i /dev/sda1
ntfsresize v2.0.0 (libntfs 10:0:0)

Program received signal SIGSEGV, Segmentation fault.
0x0015a8c8 in ntfs_volume_startup (dev=0x9e89848, flags=3) at volume.c:403
403		if (vol->mftmirr_na->rl[0].lcn != vol->mftmirr_lcn ||
(gdb) bt
#0  0x0015a8c8 in ntfs_volume_startup (dev=0x9e89848, flags=3) at volume.c:403
#1  0x0015ab99 in ntfs_device_mount (dev=0x9e89848, flags=3) at volume.c:903
#2  0x0015be96 in ntfs_mount (name=0xbff0e6fd "/dev/sda1", flags=3)
    at volume.c:1328
#3  0x0804cdff in main (argc=3, argv=0xbff0e4a4) at ntfsresize.c:2267

(gdb) print vol->mftmirr_na
$1 = (ntfs_attr *) 0x9e89a08
(gdb) print vol->mftmirr_na->rl
$2 = (runlist_element *) 0x0
(gdb) print *vol->mftmirr_na
$3 = {rl = 0x0, ni = 0x9e899a8, type = AT_DATA, name = 0x8055234, 
  name_len = 0, state = 3, allocated_size = 4096, data_size = 4096, 
  initialized_size = 4096, compressed_size = 0, compression_block_size = 0, 
  compression_block_size_bits = 0 '\0', compression_block_clusters = 0 '\0', 
  crypto = 0x0, list_entry = {next = 0x9e899fc, prev = 0x9e899fc}, 
  nr_references = 1}
(gdb) l
398		if (ntfs_attr_map_runlist(vol->mftmirr_na, 0) < 0) {
399			ntfs_log_perror("Failed to map runlist of $MFTMirr/$DATA");
400			goto error_exit;
401		}
402		/* Check $MFTMirr runlist. */
403		if (vol->mftmirr_na->rl[0].lcn != vol->mftmirr_lcn ||
404				vol->mftmirr_na->rl[0].length < (vol->mftmirr_size *
405				vol->mft_record_size + vol->cluster_size - 1) /
406				vol->cluster_size) {
407			ntfs_log_error("$MFTMirr location mismatch or first 4 records "

Version-Release number of selected component (if applicable):
ntfsprogs-2.0.0-4.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install F9-beta
2. Select "Resize existing partition" in drop down
3. *boom* ntfsresize segfaults
Comment 1 Luke Macken 2008-03-25 10:13:42 EDT
I posted this error on the upstream forum:
http://forum.linux-ntfs.org/viewtopic.php?p=2727
Comment 2 Luke Macken 2008-03-25 12:30:27 EDT
I'm able to resolve this segfault by removing the ntfsprogs-2.0.0-glibc27-open.patch
Comment 3 Tom "spot" Callaway 2008-03-25 12:40:43 EDT
Weirdness. OK, dropping the patch and rebuilding now.
Comment 4 Tom "spot" Callaway 2008-03-25 12:53:35 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=43801

Please try that out and confirm that it doesn't fail anymore.
Comment 5 Luke Macken 2008-03-25 13:37:32 EDT
Works for me!

Note You need to log in before you can comment on or make changes to this bug.