Bug 438850 - Error message when turning encryption off with iwl4965
Summary: Error message when turning encryption off with iwl4965
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-25 16:32 UTC by Mike Iglesias
Modified: 2008-05-02 20:40 UTC (History)
1 user (show)

Fixed In Version: kernel-2.6.24.5-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 20:40:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Iglesias 2008-03-25 16:32:11 UTC
Description of problem:

Turning off encryption on Intel 4965 gives an error message.

# /sbin/iwconfig wlan0 key off
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; No such file or directory.

/etc/sysconfig/network-scripts/ifup-wireless does this, and results in an error
message during boot.

Running iwconfig under strace shows that the SIOCSIWENCODE ioctl call is
returning -1.


Version-Release number of selected component (if applicable):
kernel 2.6.24.3-34

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

the error message above

Expected results:

No error message.

Additional info:

Comment 1 John W. Linville 2008-03-25 18:07:38 UTC
FWIW, it would be fair to close this as NOTABUG.  That message, while 
annoying, is merely telling you that you are disabling encryption that was 
already disabled.

But, since I've taken an interest in removing this annoyance upstream and hope 
to have a patch merged soon, I'll keep this open for now.

Comment 2 Mike Iglesias 2008-03-26 23:24:10 UTC
Ok, thanks.  I reported it because another laptop I have doesn't do that with an
older Cisco PCMCIA wireless card so I thought it might be reporting something
that wasn't really an error.


Comment 3 John W. Linville 2008-03-27 15:00:05 UTC
Don't get me wrong -- it is annoying!  FWIW, it should be gone in -58.fc8 
(although you might want to wait for -59.fc8)...


Note You need to log in before you can comment on or make changes to this bug.