Bug 438868 - pk-install-file requires network access to install local files
pk-install-file requires network access to install local files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
NeedsRetesting
: Reopened
Depends On:
Blocks: F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-03-25 13:35 EDT by Jeremy Katz
Modified: 2008-05-02 21:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 21:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-03-25 13:35:20 EDT
If installing a package off of local media when you don't have a network
available, you get a nice long traceback rather than a nice error message.  And
given that the package's dependencies are fulfilled with what is resolved, it
probably shouldn't even require the repos to be up.
Comment 1 Richard Hughes 2008-03-25 20:20:38 EDT
Agreed. What was the traceback? Thanks.
Comment 3 Richard Hughes 2008-03-30 12:42:31 EDT
This should work with 0.1.10 - can you please confirm or re-open this bug. Thanks.
Comment 4 Jeremy Katz 2008-04-11 10:16:57 EDT
It doesn't traceback now, but it still doesn't let me install packages.  I get a
dialog that says "No network connection available" (etc, etc).  But the fact
that there's no network connection is irrelevant to installing a local package
which has all of its deps already satisfied
Comment 5 Matthias Clasen 2008-04-12 22:29:31 EDT
I just tried with system-install-packages, and it successfully installed a local
package without network.
Comment 6 Richard Hughes 2008-04-13 06:10:37 EDT
Jeremy, can you try again with the latest package in rawhide please? Thanks.
Comment 7 Jeremy Katz 2008-04-14 22:42:40 EDT
Still fails for me.  Booted and never had network available.  Then I click on
the package that's on my USB key (that has the firmware for my wireless card, so
that I can _get_ a network connection) and I still get the network error.

If I plug in the network and let repo bits get downloaded and then take down the
network, it's fine.
Comment 8 Richard Hughes 2008-04-18 07:57:06 EDT
Robin, do you want that fix you committed cherry-picked to stable?
Comment 9 Robin Norwood 2008-04-18 10:56:11 EDT
Not yet, it isn't fixed yet, after all.  I'm working on it more today.
Comment 10 Robin Norwood 2008-04-23 10:50:14 EDT
Ok, I'm done poking with the install-file command - this bug should be fixed, as
well as giving better error messaging when things do go awry.
Comment 11 Bill Nottingham 2008-04-30 14:29:47 EDT
Is there a particular build that has this fix?
Comment 12 Robin Norwood 2008-05-01 10:37:05 EDT
This should be fixed in the rawhide versions now
(PackageKit-0:0.1.12-7.20080425.fc9.i386 and greater, for instance)

Note You need to log in before you can comment on or make changes to this bug.