Bug 438888 - fedora can't find uuid at first boot attempt
fedora can't find uuid at first boot attempt
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 15:51 EDT by cornel panceac
Modified: 2013-02-04 16:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 16:38:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the initrd after install (2.81 MB, application/octet-stream)
2008-03-26 12:09 EDT, cornel panceac
no flags Details
the point where system hangs (1.59 MB, image/jpeg)
2008-03-26 13:29 EDT, cornel panceac
no flags Details
i suppose here is the problem. (1.60 MB, image/jpeg)
2008-03-26 13:52 EDT, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2008-03-25 15:51:31 EDT
Description of problem:
after install from x86_64 livecd, fedora can't boot because it can't find uuid=.....

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install fedora from x86_64 livecd
2.reboot
3.
  
Actual results:
fedora can't boot, it can't find uuid=....

Expected results:
fedora boots

Additional info:
editing grub, i've replaced the root=uuid=... with root=/dev/sda6
it was of no use. then i've removed rhgb and quiet and added selinux=0
this does not help either.
the only relevant message i'v seen after starting udev was: no such device. and
no logical volumes found.
i've replaced the install (so that i can report this) with f9alpha (x86), but i
can reinstall if needed.
Comment 1 Bill Nottingham 2008-03-25 16:05:51 EDT
Is it reproducible?
Comment 2 Jesse Keating 2008-03-25 16:20:23 EDT
I talked with the user on IRC and another install attempt will be done.  If that
attempt reproduces the problem, the user will attach the initrd.img the
installer produced.  From discussion on IRC it sounded like possibly the
necessary modules were not loaded and thus the disks weren't seen.
Comment 3 cornel panceac 2008-03-26 12:05:01 EDT
after reinstall same error. i'll attach the initrd.
Comment 4 cornel panceac 2008-03-26 12:09:23 EDT
Created attachment 299183 [details]
the initrd after install
Comment 5 Jeremy Katz 2008-03-26 13:09:09 EDT
Can you please try to get a picture of what's on the screen when you boot.  The
initrd looks pretty sane
Comment 6 cornel panceac 2008-03-26 13:29:02 EDT
Created attachment 299196 [details]
the point where system hangs
Comment 7 cornel panceac 2008-03-26 13:52:28 EDT
Created attachment 299204 [details]
i suppose here is the problem.

as reported elsewhere, x86_64 livecd switches sda with sdb, but after install
fedora returns to the "normal" situation. so maybe that's the reason. you can
see the line wich states that
unable to access resume device /sys/block/sdb//sdb3
out of ideas :)
Comment 8 cornel panceac 2008-03-28 08:42:00 EDT
is there any other info you need?
Comment 9 cornel panceac 2008-03-28 15:15:40 EDT
same thing happens with 686 kde livecd (f9beta). i believe the reason is this:
https://bugzilla.redhat.com/show_bug.cgi?id=431638

anyway, to get over it, i disabled in bios the second hard disk (sata, seen by
the f9beta as /dev/sda _before_ install, and /dev/sdb _after_ install).

this way i was able to boot x86_64.
Comment 10 cornel panceac 2008-04-13 01:42:56 EDT
unable to access resume device /dev//sys/block/sda//sda3

stil, the system is booting.

f9beta x86_64, 
[guzu@localhost ~]$ rpm -q anaconda
anaconda-11.4.0.71-1.x86_64
[guzu@localhost ~]$ rpm -q initscripts
initscripts-8.69-1.x86_64
[guzu@localhost ~]$ rpm -q upstart
upstart-0.3.9-17.fc9.x86_64
[guzu@localhost ~]$ rpm -q fedora-release
fedora-release-8.93-1.noarch
[guzu@localhost ~]$ rpm -q kernel
kernel-2.6.25-0.204.rc8.git4.fc9.x86_64
kernel-2.6.25-0.218.rc8.git7.fc9.x86_64
[guzu@localhost ~]$ uname -r
2.6.25-0.218.rc8.git7.fc9.x86_64
[guzu@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.25-0.218.rc8.git7.fc9.x86_64 #1 SMP Wed Apr 9
19:55:19 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
[guzu@localhost ~]$ 

is interesting to note that the message is not found in dmesg or /var/log/messages


Comment 11 cornel panceac 2008-04-18 13:11:57 EDT
f9 preview live cd x86_64 performed an working install with both hard disks
enabled in bios, so, even if someone somewhere (fedora-test list) said that
drives order is chosen randomly, i believe this bug was fixed.

btw, even on the working pre-preview fully updated x86_64 rawhide, still i could
see the message:
unable to access resume device /dev//sys/block/sda//sda3
...
Comment 12 Bug Zapper 2008-05-14 02:50:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Hans de Goede 2009-02-04 16:38:43 EST
Closing per comment #11 .

Note You need to log in before you can comment on or make changes to this bug.