Bug 438893 - 4.7 release note "Upgrade mode" text change
4.7 release note "Upgrade mode" text change
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: Documentation (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Don Domingo
Content Services Development
: Documentation
Depends On:
Blocks: RHEL4u7_relnotes RHEL4u8_relnotes
  Show dependency treegraph
 
Reported: 2008-03-25 16:21 EDT by Denise Dumas
Modified: 2009-08-19 23:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 21:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denise Dumas 2008-03-25 16:21:56 EDT
Description of problem:

The 4.7 release notes need a similar change to what we just did for 5.2
regarding "Upgrade mode". 

Here is the old text: 
"In order to upgrade an existing Red Hat Enterprise Linux 4 installation to Red
Hat Enterprise Linux 4.7, you must use Red Hat Network to update those packages
that have changed.
You can also use Anaconda to perform a fresh installation of Red Hat Enterprise
Linux 4.7 or to perform an upgrade from /the latest updated version/ of Red Hat
Enterprise Linux 4."

Here is the suggested new text: 
"Red Hat recommends that users updating from one minor version of Red Hat
Enterprise Linux 4 (such as 4.5 or 4.6) to Red Hat Enterprise Linux 4.7
do so from Red Hat Network using the hosted Web user interface or Red Hat
Network Satellite.

If no network connectivity is available, an update can still be
performed offline using anaconda's "upgrade" functionality.  Note that
anaconda has limited abilities to handle issues such as dependencies on
additional repositories or third-party applications, and anaconda reports
installation errors in a log file, not interactively. Because of these
limitations, Red Hat advises customers 
to test and verify offline updates using the exact configuration before
applying the update to the actual target environment, and to carefully
review the update log for errors after applying the update.

Red Hat does not support in-place upgrades between major versions of Red
Hat Enterprise Linux.  Although anaconda's "upgrade" option will allow
users to perform an upgrade from earlier major versions of Red Hat
Enterprise Linux (such as Enterprise Linux 3 to Enterprise Linux 4),
there is no guarantee that the upgrade will result in a working
configuration.  In-place upgrades across major releases do not preserve
all system settings, services, and custom configurations.  For this
reason, Red Hat strongly recommends that you perform a fresh
installation rather than a system upgrade between major versions.
Comment 1 Don Domingo 2008-03-26 00:01:21 EDT
thanks Denise, revising as:

<quote>
When updating from one minor version of Red Hat Enterprise Linux 4 (such as 4.5
to 4.6) to Red Hat Enterprise Linux 4.7, it is recommended that you do so using
Red Hat Network, whether through the hosted web user interface or Red Hat
Network Satellite.

If you are upgrading a system with no available network connectivity, use the
"Upgrade" functionality of Anaconda. However, note that Anaconda has limited
abilities to handle issues such as dependencies on additional repositories or
third-party applications. Further, Anaconda reports installation errors in a log
file, not interactively.

As such, it is recommended that when upgrading offline systems, you should test
and verify the integrity of your upgrade configuration first. Be sure to
carefully review the update log for errors before applying the upgrade to your
production environment.

In-place upgrades between major versions of Red Hat Enterprise Linux (for
example, upgrading from Red Hat Enterprise Linux 3 to Red Hat Enterprise Linux
4.7) is not supported. While the "Upgrade" option of Anaconda allows you to
perform this, there is no guarantee that the upgrade will result in a working
installation. In-place upgrades accross major releases do not preserve all
system settings, services, and custom configurations. For this reason, it is
strongly recommended that you perform a fresh installation when planning to
upgrade between major versions.
</quote>

please advise if any further revisions are required. thanks!
Comment 2 Don Domingo 2008-03-31 19:15:41 EDT
Hi Denise,

In the RHEL5.2 release notes, the "upgrade statement" appears as follows:

<quote>
Note that upgrading from beta releases to GA releases is not supported. Further,
Red Hat does not support in-place upgrades between major versions of Red Hat
Enterprise Linux. Although Anaconda provides an option that allows an upgrade
from earlier major versions of Red Hat Enterprise Linux (such as Enterprise
Linux 4 to Enterprise Linux 5), there is no guarantee that the upgrade will
result in a fully functional configuration. In-place upgrades across major
releases do not preserve all system settings, services, and custom
configurations. For this reason, Red Hat strongly recommends that you perform a
fresh installation rather than a system upgrade between major versions.
</quote>

here, upgrading from RHEL4.x to RHEL5.x is "not recommended". however, in the
RHEL4.7 release notes (as per this bug), upgrading from RHEL3.x to RHEL4.x is
"not supported".

my question is: should upgrading across major releases be unsupported for both
RHEL3.x-4.x and RHEL4.x-5.x? Or is it simply "unsupported" in RHEL3.x-4.x
because RHEL3 is now in maintenance mode?

please advise. thanks!
Comment 3 Don Domingo 2008-06-02 19:16:53 EDT
Hi,

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL4u7relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.