Bug 43890 - screen resolution and color depth
screen resolution and color depth
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 15:29 EDT by Stephen P. Cohen
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-09 00:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm XFree log (20.95 KB, text/plain)
2001-06-08 12:34 EDT, Stephen P. Cohen
no flags Details
root XFree log (21.33 KB, text/plain)
2001-06-08 12:35 EDT, Stephen P. Cohen
no flags Details
XF86Config (13.81 KB, text/plain)
2001-06-08 12:47 EDT, Stephen P. Cohen
no flags Details
XF86Config-4 (1.30 KB, text/plain)
2001-06-08 12:47 EDT, Stephen P. Cohen
no flags Details

  None (edit)
Description Stephen P. Cohen 2001-06-07 15:29:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Xconfigurator, when launching the Xterm to test the entries, remains at 
the 'grey screen' and no longer displays the box asking if the box can be 
seen.  Ctrl-alt-bksp must be used to return to Xconfigurator.

Hardware:
  Dell Precision 410 system unit (nVidia TNT2, 32Mb graphics on board)
  Dell M770 monitor

How reproducible:
Always

Steps to Reproduce:
1. launch Xconfigurator
2. autoprobe for card & monitor, choose any color depth/resolution
3. wait (forever) for box to be displayed asking if box can be seen
	

Actual Results:  When the xterm starts (grey screen), nothing more happens.

Expected Results:  A box should be displayed asking if the box can be seen.

Additional info:

The Xconfigurator had run successfully in the past.  Just prior to this 
attempt, XFree86 was attempted to be updated from 4.0.1 to 4.0.3-5, 
however, only XFree86-libs and XFree-xfs were successful.  XFree86, 
itself, aborts when RPM tries to update from 4.0.1 to 4.0.3-5.

I am now unable to use the system because it appears to be in 8-bit color 
mode.  My application pull-down windows show white letters on white 
background, making them unreadable.
Comment 1 Stephen P. Cohen 2001-06-07 15:31:32 EDT
The problem with RPM is described in a bugzilla - search for 'rpm md5'.
Comment 2 Mike A. Harris 2001-06-08 12:13:00 EDT
Please provide the exact complete full error message you receive.
You can cut and paste it into a file and then attach the file to the bug
report.  I also will need your XFree86 server logs and config file attached
uncompressed using the link below.
Comment 3 Stephen P. Cohen 2001-06-08 12:34:40 EDT
Created attachment 20632 [details]
gdm XFree log
Comment 4 Stephen P. Cohen 2001-06-08 12:35:16 EDT
Created attachment 20633 [details]
root XFree log
Comment 5 Stephen P. Cohen 2001-06-08 12:40:29 EDT
No errors are visible on the screen.  As described in the main body, the screen
goes 'grey', awaiting the presence of something to be displayed.  Nothing gets
displayed.  ctrl-alt-bksp returns the screen to the prior image (the desktop
containing the terminal window from which Xconfigurator was launched). 
Xconfigurator indicates that there is a problem with the X system.

I believe the problem to be related to the aborted attempt to upgrade from
XFree86 4.0.1 to 4.0.3.  However, I am unable to revert back to 4.0.1 for the
same problem preventing the upgrade - an MD5 issue from RPM when updating or
un-updating.

The system currently works, but appears to be 'stuck' in whatever screen mode it
is.  I can't tell which, but it appears to be at least 12kx10k at 60Mhz in 8 bit
depth.  Resolution cannot be changed via ctrl-alt-plus.
Comment 6 Stephen P. Cohen 2001-06-08 12:47:04 EDT
Created attachment 20634 [details]
XF86Config
Comment 7 Stephen P. Cohen 2001-06-08 12:47:20 EDT
Created attachment 20635 [details]
XF86Config-4
Comment 8 Mike A. Harris 2001-06-09 00:44:13 EDT
Your packages are mixed up.  You've got some 4.0.1 and some 4.0.3 packages
installed.  This is not going to work.  Also, any MD5 messages you see, are
not errors, they are warnings to you that your package is corrupt.  This
means when you downloaded it it got corrupted.  You'll need to download
all of the XFree86 4.0.3 packages, as well as the latest Xconfigurator, and
the rest of the packages that 4.0.3 requires.

First step is to uninstall all currently installed XFree86 packages, and
verify there are no more installed with:  rpm -qa |sort|grep XFree86
it should report nothing.  Then install the new packages.

I should also note that, while 4.0.3 will work in Guinness, it is not supported
configuration as we have never officially released packages for Guinness.
Also, DRI will not work, and *must* be disabled.  If you require DRI, then
you will have to also upgrade to a 2.4.x kernel, and then upgrade a slew
of other items as well.  In the end upgrading to Seawolf properly is the
easiest solution.
Comment 9 Luis Cortes 2002-10-19 23:02:06 EDT
I have a similar problem with the same monitor.  I have a black screen when I 
dock my laptop to a DELL M770 monitor.  I have RH8.0 on a Dell laptop, docking 
to a DELL docking station, with a Dell monitor (this should be a receipe for 
success).  But, when I try to configure my system with redhat-config-x86free, 
my screen goes blank until control-alt-backspace.
Since I also have XP on the same machine, I have tried it and XP detects and 
manhandles my dell monitor fine.

Note You need to log in before you can comment on or make changes to this bug.