Bug 43891 - rpmlint error (incoherent-subsys) against 7.1 squid rpm
Summary: rpmlint error (incoherent-subsys) against 7.1 squid rpm
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-07 19:29 UTC by Jay Turner
Modified: 2015-01-07 23:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 19:29:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen Foster 2001-06-07 19:29:51 UTC
Description of Problem: rpmlint throws an error message against the 7.1
squid rpm


How Reproducible: always


Steps to Reproduce:
1. Install 7.1 on an x86 system
2. Mount 7.1 OS CD#2
3. rpmlint /mnt/cdrom/RedHat/RPMS/squid-2.3.STABLE4-10.i386.rpm

Actual Results:
E: squid incoherent-subsys /etc/rc.d/init.d/squid $SQUID

Expected Results: no output expected


Additional Information:

Comment 1 Bill Nottingham 2001-06-08 15:32:36 UTC
It's a valid use. In theory, rpmlint could interpret the shell script and
figure out what $SQUID evaluates to, but it's not really practical.


Note You need to log in before you can comment on or make changes to this bug.