Bug 438912 - prism54_get_wireless_stats+0x21/0x9c [prism54]
Summary: prism54_get_wireless_stats+0x21/0x9c [prism54]
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-25 21:57 UTC by Ronald Warsow
Modified: 2008-04-02 15:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 15:27:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages exerpt (6.84 KB, text/plain)
2008-03-25 23:50 UTC, Peter F. Patel-Schneider
no flags Details
0001-prism54-correct-thinko-in-prism54-Convert-stats_s.patch (1.10 KB, patch)
2008-03-26 19:24 UTC, John W. Linville
no flags Details | Diff

Description Ronald Warsow 2008-03-25 21:57:12 UTC
Description of problem:
BUG: lock held when returning to user space!

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.121.rc5.git4.fc9.x86_64
kernel-2.6.25-0.141.rc6.git5.fc9.x86_64


How reproducible:
load the module

Steps to Reproduce:
1.
2.
3.
  
Actual results:
excerpt

Mar 25 17:57:51 f9 console-kit-daemon[2135]: WARNING: Couldn't read
/proc/2875/environ: Error reading file '/proc/2875/environ': No such process
Mar 26 04:15:30 f9 kernel: warning: process `system-config-f' used the
deprecated sysctl system call with 1.23.
Mar 26 04:15:30 f9 kernel: 
Mar 26 04:15:30 f9 kernel: ================================================
Mar 26 04:15:30 f9 kernel: [ BUG: lock held when returning to user space! ]
Mar 26 04:15:30 f9 kernel: ------------------------------------------------
Mar 26 04:15:30 f9 kernel: system-config-f/4088 is leaving the kernel with locks
still held!
Mar 26 04:15:30 f9 kernel: 1 lock held by system-config-f/4088:
Mar 26 04:15:30 f9 kernel:  #0:  (&priv->stats_lock){--..}, at:
[_end+109199257/2109760552] prism54_get_wireless_stats+0x21/0x9c [prism54]
Mar 26 04:15:54 f9 kerneloops: Submitted 1 kernel oopses to www.kerneloops.org

Expected results:


Additional info:
this happens with and without the firmware[1]. in the later case the box behaves
crazy. on "input field" eg. console or firefox adresse line all letters gets
repeated indefinitely. "a" becomes "aaaaaaaaaaaaaaaaaaaaaaaaa....."


same seen on F8 kernel since 2.6.24.3-34.fc8

[1]
I got two of this prism54 cards.
up to F9 beta on this box, where this bz is about, always isl3886 firmware was
loaded eg. p54pci module was active. 
on the other box was always isl3890 firmware loaded eg. prism54. 
both cards were operating.

Comment 1 Peter F. Patel-Schneider 2008-03-25 23:50:58 UTC
Created attachment 299083 [details]
/var/log/messages exerpt

Here is a similar problem, maybe.

Unfortunately, I could not repeat the problem, and I was fooling around with
NetworkManager at the time - disabling and enabling wireless and changing
between various APs.  

The good news is that iwl3945 and NetworkManager managed to work in other
conditions, and didn't fail at all when I rebooted to the current version of
F9beta.

Comment 2 John W. Linville 2008-03-26 18:58:14 UTC
Peter, I believe the issue you are seeing is actually the same as in bug 
438584 -- please use that to track the issue.

Comment 3 John W. Linville 2008-03-26 19:24:58 UTC
Created attachment 299218 [details]
0001-prism54-correct-thinko-in-prism54-Convert-stats_s.patch


Note You need to log in before you can comment on or make changes to this bug.