Bug 438915 - autofs autofs-5.0.3-8 rejects my LDAP master map
autofs autofs-5.0.3-8 rejects my LDAP master map
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 18:10 EDT by Jason Tibbitts
Modified: 2008-11-10 23:17 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.3-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 23:17:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2008-03-25 18:10:54 EDT
I updated my rawhide machine today and found that autofs no longer likes the
automount maps it gets via LDAP.  The same maps work fine on all of the other
systems and were working fine previous to this update.

I am currently running autofs-5.0.3-8.i386; the previous version which worked
was autofs-5.0.3-6.i386.  I'm not sure if -7 made it out to the mirrors.

I turned on some debugging and extracted some data from the logs; it seems that
it doesn't like the master map:

Mar 25 11:12:07 temp2 automount[2662]: syntax error in map near [ /home ]
Mar 25 11:12:07 temp2 automount[2662]: syntax error while parsing map.

But the map in question is just:

# /home, auto.master, math.uh.edu
dn: cn=/home,nisMapName=auto.master,dc=math,dc=uh,dc=edu
objectClass: nisObject
cn: /home
nisMapName: auto.master
nisMapEntry: ldap:nisMapName=auto.home,dc=math,dc=uh,dc=edu

I can attach more of the log if you need it, but I'm guessing that the recent
changes to the master map parser have made things a bit stricter.
Comment 1 Jason Tibbitts 2008-03-25 18:15:26 EDT
Just for kicks, I rebuilt without autofs-5.0.3-map-type-in-map-name.patch and
things work fine now.
Comment 2 Ian Kent 2008-03-26 00:15:31 EDT
Oops, didn't catch that.
Try revision 9, which should be on it's way to the mirrors now.
Comment 3 Jason Tibbitts 2008-03-26 11:18:35 EDT
-9 seems to work fine, thanks.
Comment 4 Ian Kent 2008-03-30 00:01:47 EDT
I've discovered a case where my initial patch didn't work.
Could you revision 10 when you get a chance please.
Comment 5 Ian Kent 2008-03-30 00:03:37 EDT
(In reply to comment #4)
> Could you revision 10 when you get a chance please.

Ha, that would be "Could you test out revision 10".
Sorry for the inconvenience.
Ian
Comment 6 Jason Tibbitts 2008-03-31 11:46:03 EDT
Unfortunately autofs-5.0.3-10.i386 does not work for me; I'm back to the
original error output:

Mar 31 10:43:31 temp2 automount[2737]: lookup_read_master: lookup(ldap):
searching for "(objectclass=nisObject)" under
"nisMapName=auto.master,dc=math,dc=uh,dc=edu"
Mar 31 10:43:31 temp2 automount[2737]: lookup_read_master: lookup(ldap):
examining entries
Mar 31 10:43:31 temp2 automount[2737]: syntax error in map near [ /home ]
Mar 31 10:43:31 temp2 automount[2737]: syntax error while parsing map.
Comment 7 Ian Kent 2008-04-01 00:05:15 EDT
*sigh*, please try revision 11.
Comment 8 Jason Tibbitts 2008-04-01 11:34:08 EDT
-11 seems to work OK.
Comment 9 Bug Zapper 2008-05-14 02:51:22 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Ian Kent 2008-11-10 23:17:26 EST
Looks like this is should be fixed in the latest update so
I'm closing the bug. Please re-open if this is still a problem.

Note You need to log in before you can comment on or make changes to this bug.