Bug 438919 - RHEL5.2: add cantiga IDs to agpgart driver
RHEL5.2: add cantiga IDs to agpgart driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Geoff Gustafson
Martin Jenner
: OtherQA
Depends On:
Blocks: 245607
  Show dependency treegraph
 
Reported: 2008-03-25 19:01 EDT by Geoff Gustafson
Modified: 2009-06-19 23:00 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport of upstream agpgart cantiga id patch (4.04 KB, patch)
2008-03-25 19:02 EDT, Geoff Gustafson
no flags Details | Diff
resolution 800x600 screen shot (89.90 KB, image/jpeg)
2008-03-28 02:34 EDT, Jane Lv
no flags Details

  None (edit)
Description Geoff Gustafson 2008-03-25 19:01:04 EDT
The updated intel graphics driver in 5.2 Beta includes early support for Cantiga
graphics (part of the Montevina mobile platform). However, Intel testing of the
Beta revealed that this agpgart update was needed for the driver to load.

I found the relevant patch upstream and backported it to 5.2.
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=4e8b6e25943a22036a6b704ebef634c7dec4c10e
Comment 1 Geoff Gustafson 2008-03-25 19:02:15 EDT
Created attachment 299082 [details]
backport of upstream agpgart cantiga id patch

This is the backported patch for 5.2, which I've tested on Montevina.
Comment 2 Peter Martuccelli 2008-03-26 12:52:50 EDT
Patch is acceptable, other then poor timing, for R5.2.
Comment 10 Jane Lv 2008-03-28 02:32:14 EDT
I applied Geoff's patch to RHEL5.2-sp1 kernel source and rebuilt it.  agpgart
works for Cantiga driver.

But I found a bug in the Cantiga 2D driver.  If the display resolution is
changed to low (1024x768, 800x600 or 640x480), there are 2 black borders at the
top and bottom of the screen.  Resolution with 1280x1024 works fine.

The screenshot will be attached.
Comment 11 Jane Lv 2008-03-28 02:34:21 EDT
Created attachment 299436 [details]
resolution 800x600 screen shot
Comment 12 Don Zickus 2008-04-02 12:10:07 EDT
in kernel-2.6.18-88.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 17 Cameron Meadors 2008-04-23 16:24:30 EDT
agpgart must be working because intel driver works.
Comment 20 errata-xmlrpc 2008-05-21 11:12:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.