Bug 43892 - rpmlint error (use-of-home-in-%post) against 7.1 postgresql-server rpm
Summary: rpmlint error (use-of-home-in-%post) against 7.1 postgresql-server rpm
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-07 19:32 UTC by Jay Turner
Modified: 2015-01-07 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 20:09:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen Foster 2001-06-07 19:32:08 UTC
Description of Problem: rpmlint throws an error message against 7.1
postgresql-server rpm


How Reproducible: always


Steps to Reproduce:
1. Install 7.1 on x86 system
2. Mount OS CD#1
3. rpmlint /mnt/cdrom/RedHat/RPMS/postgresql-server-7.0.3-8.i386.rpm

Actual Results:
E: postgresql-server use-of-home-in-%post

Expected Results: no output expected


Additional Information:

Comment 1 Trond Eivind Glomsrxd 2001-06-07 19:46:27 UTC
It appends information to the ~/.bashrc for the server-specific user in post,
the account is created in pre. Not a problem. A workaround could be deviced to
get rid of the warning, but it would just get rid of the warning and not solve
any fundamental problems.

Comment 2 Glen Foster 2001-06-07 20:09:19 UTC
I'm trying to determine if I should ignore this message in the automated rpmlint
tests.  Should I just not worry about this message and filter it out, or are you
planning on making a change to this rpm (I couldn't tell from your response)?

Comment 3 Trond Eivind Glomsrxd 2001-06-07 20:13:08 UTC
I'll probably work around it (I'm adding this along with other changes right
now), but it's not a bug.


Note You need to log in before you can comment on or make changes to this bug.