Bug 438920 - Error unmounting usb hard disk
Error unmounting usb hard disk
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://img249.imageshack.us/img249/86...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 19:06 EDT by Jonay
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 09:04:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of required command (12.80 KB, text/plain)
2008-03-26 11:11 EDT, Jonay
no flags Details
Output of required command (22.08 KB, text/plain)
2008-03-26 11:12 EDT, Jonay
no flags Details

  None (edit)
Description Jonay 2008-03-25 19:06:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
When I tried to safely remove a LaCie USB hard disk, Fedora stated that it could be unmounted, but not removed (or ejected). The drive icon remained on the desktop.

Version-Release number of selected component (if applicable):
unknown

How reproducible:
Always


Steps to Reproduce:
1.Right click on the drive icon present on the desktop.
2.Select "Safe extract" ("Extracción segura in Spanish")


Actual Results:
The captured window popped up.

Expected Results:
The drive should have been successfully extracted, the trash folder emptied, and the icon of the drive removed from the desktop.

Additional info:
Comment 1 Rex Dieter 2008-03-26 07:34:54 EDT
In kde, gnome?

What is the output of 
/usr/sbin/lsof | grep media
?

(If needed you may need to install lsof)
Comment 2 Jonay 2008-03-26 11:11:21 EDT
Created attachment 299170 [details]
Output of required command

Output before trying to unmount the USB hard drive.
Comment 3 Jonay 2008-03-26 11:12:45 EDT
Created attachment 299171 [details]
Output of required command

Output of command after trying to unmount the USB Hard Disk.
Comment 4 Jonay 2008-03-26 11:13:37 EDT
Sorry, I forgot about the two flavors of Fedora... I'm using KDE.

Since I'm not very sure if you need the output before trying to unmount it or 
after, I'm attaching both as plain text files.

And of course, If you need more info, just ask. :)
Comment 5 Chitlesh GOORAH 2008-04-07 06:36:25 EDT
Please note that kio_resources has nothing to do with how usb disks are mounted.

kio_resources provides the "resources" protocol for KDE. It allows you to browse
all installed files in the standard search paths (generally .kde and /usr). The
general format of a resources URL is resources:/resource-type[/relative-path].
Thus, to view all wallpapers installed on your system, both in your home
directory and in the KDE installation path, you type resources:/wallpaper. If
you simply want to look through all the available resource types, use resources:/.

This is why you wrote:
> Version-Release number of selected component (if applicable):
> unknown
Comment 6 Rex Dieter 2008-04-07 07:40:48 EDT
reassigning -> kdebase
Comment 7 Ngo Than 2008-04-07 08:41:19 EDT
i cannot reproduce it with KDE-4.0.3 in FC8 update. Can anyone reproduce this 
problem?

if you does manually with umount /media/DEVICE, does it work for your?

i saw the screenshot bugzh4.jpg but cannot read. Could you please make new 
screenshot with en_US? Thanks
Comment 8 Kevin Kofler 2008-04-07 08:51:33 EDT
The error message says "The device was unmounted correctly, but could not be 
ejected." It's normal that a hard disk can't be ejected. :-) So I think the 
error is mostly harmless.
Comment 9 Lukáš Tinkl 2008-04-07 09:04:04 EDT
Happends to me as well, it's not an error, merely an information message
Comment 10 Kevin Kofler 2008-04-07 09:36:47 EDT
Still, does it really make sense to show this message when the device isn't 
even expected to be ejectable? IIRC I saw a patch for this in some other 
distro's patchset (must have been either Kubuntu or openSUSE).
Comment 11 Jonay 2008-04-19 07:27:02 EDT
I don't understand a thing... It seems to have fixed itself on the last week, 
I don't get the error when I safely remove my hdd. Well, I suppose this is the 
end of this bug. Thanks a lot everyone. :)

Note You need to log in before you can comment on or make changes to this bug.