Bug 438931 - Perl + MRTG failures : redefinition of subroutines
Perl + MRTG failures : redefinition of subroutines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 20:43 EDT by Austin
Modified: 2008-04-20 20:02 EDT (History)
0 users

See Also:
Fixed In Version: 2.16.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-20 20:02:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of the problem reported by MRTG every 5 mins. (2.36 KB, text/plain)
2008-03-25 20:43 EDT, Austin
no flags Details

  None (edit)
Description Austin 2008-03-25 20:43:45 EDT
Description of problem: Lots of redefinition errors in an email every 5 mins.


Version-Release number of selected component (if applicable):
Perl: 5.10.0-20.fc9.x86_64
MRTG: 2.15.1-8.fc9.x86_64

How reproducible: Every 5 mins...


Steps to Reproduce:
1. Updated Fedora 9a via yum, and these started appearing.
2.
3.
  
Actual results:
Incompatibility between a Perl release and MRTG?

Expected results:
No unusual emails.

Additional info:
Available upon request.
After fixing duplicate versions being installed of some Perl modules, 17 modules
were updated and 6 were installed.

I've attached a sample email. I won't attach the 170 other duplicates ;-)
Comment 1 Austin 2008-03-25 20:43:45 EDT
Created attachment 299084 [details]
Copy of the problem reported by MRTG every 5 mins.
Comment 2 Vitezslav Crhonek 2008-03-26 08:41:31 EDT

*** This bug has been marked as a duplicate of 437681 ***
Comment 3 Austin 2008-04-17 19:58:57 EDT
As per comment #19 from bug #437681, I'm re-opening this bug to see if the
problem can be tackled from this end.
Comment 4 Austin 2008-04-17 20:01:06 EDT
The problem still exists with these versions of packages:
* mrtg-2.15.1-8-fc9.x86_64
* perl-5.10.0-20.fc9.i386
* perl-IO-Socket-INET6-2.54-1.fc9.noarch
* perl-SNMP_Session-1.08-4.fc9.noarch
Comment 5 Austin 2008-04-20 20:02:31 EDT
With the latest version of MRTG (v2.16.1-1.fc9.x86_64) this problem has been
fixed. I can verify that I no longer receive 5 minute complaints :-D

Note You need to log in before you can comment on or make changes to this bug.