Bug 438954 - Installer doesn't recognize LUKS encrypted partitions
Installer doesn't recognize LUKS encrypted partitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 02:35 EDT by Stefan Becker
Modified: 2008-04-04 17:56 EDT (History)
0 users

See Also:
Fixed In Version: anaconda-11.4.0.62-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 11:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2008-03-26 02:35:17 EDT
My laptop (running Fedora 8 right now) has a LVM with 3 LUKS encrypted
partitions (root, swap, home) on it. When I run the Fedora 9 Beta installer they
show up as "foreign".

The installer should recognize those and offer me to add them to the mount list.
Comment 1 Jeremy Katz 2008-03-26 09:41:47 EDT
We're not currently making use of preexisting LUKS partitions in this installer.  
Comment 2 David Lehman 2008-04-04 11:50:50 EDT
As of anaconda-11.4.0.62-1 you should get prompted for a passphrase for each of
these partitions (Or are they LVs? It should work in either case.). If the
passphrase you supply gives access, the devices' contents will be reflected in
the partitioning screens.
Comment 3 Stefan Becker 2008-04-04 17:56:23 EDT
The newest version of anaconda recognizes my pre-existing LV LUKS partitions and
asks for a password. After that it correctly unlocks them and detects the
correct file system type.

But the encrypted setup is still not working out-of-the-box. See followup bug
#441001

Note You need to log in before you can comment on or make changes to this bug.