This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 43896 - script command in pump.conf does not work.
script command in pump.conf does not work.
Status: CLOSED DUPLICATE of bug 32718
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 16:11 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 16:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-07 16:11:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Pump does not execute scripts in /etc/pump.conf

How reproducible:
Always

Steps to Reproduce:
1. Write a script which will echo something to a file.
2. edit pump.conf to include the script
3. ifdown ifup or pump your dhcp interface
	

Actual Results:  Script never runs

Expected Results:  Script should execute with arguments passed per man page
     

Additional info:

I have a script which I use to update dynamic dns when my dhcp assigned 
address changes. I would like to be able to have this script run only when 
pump sees the interface go up or renew its ip address rather than in a 
cron job.
Thanks in Advance
Comment 1 Need Real Name 2001-06-08 10:46:28 EDT

*** This bug has been marked as a duplicate of 32718 ***

Note You need to log in before you can comment on or make changes to this bug.