This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 438961 - CPU frequency scaling unsupported
CPU frequency scaling unsupported
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cpufreq-utils (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 03:52 EDT by Nicholas
Modified: 2008-04-03 10:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 10:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (27.59 KB, text/plain)
2008-03-28 03:07 EDT, Nicholas
no flags Details

  None (edit)
Description Nicholas 2008-03-26 03:52:46 EDT
Description of problem:
CPU frequency scaling does not support intel PE 2180 on a Nvidia 650i MB

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jarod Wilson 2008-03-26 08:59:03 EDT
Please provide the contents of /proc/cpuinfo and a dmesg dump from a fresh boot
with cpufreq.debug=7 added as a kernel boot parameter.
Comment 2 Nicholas 2008-03-28 03:07:23 EDT
Created attachment 299438 [details]
dmesg

i add cpufreq.debug=7 as as a kernel boot parameter then i find the file named
cpuinfo under /proc, but it's 0byte file

i upload a copy of dmesg.
Comment 3 Nicholas 2008-03-28 03:15:48 EDT
why is cpuinfo 0byte file ?
help me to solve then i will upload it.
Comment 4 Jarod Wilson 2008-03-28 10:38:41 EDT
Hrm... I'm not seeing any evidence that the cpuspeed service is starting up. Do
you have the cpuspeed package installed, and if so, is it starting on boot?
Quick check would be to simply issue the command:

/sbin/service cpuspeed start

The output from that (or lack thereof) ought to shed some light, I think.

As for the 0-byte /proc/cpuinfo... No clue how that could happen, but it doesn't
sound particularly good. Just had another thought... The cpuspeed init script
actually keys off some info in /proc/cpuinfo these days, so if you don't have
it, that could actually be part of why freq scaling isn't getting set up.

I don't suppose there's a bios update available for your board that might also help?
Comment 5 Nicholas 2008-03-30 05:30:32 EDT
I freshly install fedora 8 and fedora 9 beta,keep all default, then reboot 
after "firstboot", it  pop-up a window showing:"CPU frequency scaling 
unsupported".

After that i follow your instruction and get the cpuinfo, i donn't know where 
the fault lies

i check the "service", make sure of CPUSPEED start up in level 3,4,5

sorry for my english, it may suck.
Comment 6 Jarod Wilson 2008-03-31 12:28:32 EDT
Okay, if you get 'CPU frequency scaling unsupported', then the acpi-cpufreq
driver doesn't work with your processor. Best as I can tell, a PE2180 processor
is a Pentium 4-derived dual-core cpu (possibly in the Pentium D line), so I
believe we're actually doing the right thing here.

You might get cpu throttling using the p4-clockmod driver, but for various
reasons, the p4-clockmod driver is terrible so we don't enable it. There's a
comment in /etc/sysconfig/cpuspeed that points here for some reference info on
p4-clockmod: http://lkml.org/lkml/2006/2/25/84.

If you find evidence this processor actually *should* be supported by the
acpi-cpufreq driver, then the fault probably lies with the system's BIOS. In
that case, it might be worth finding a BIOS update, but I'm pretty sure this is
simply a cpu that doesn't support sane cpu frequency scaling.
Comment 7 Nicholas 2008-04-02 22:36:46 EDT
My bios is the newest.
i donn't think it's a problem of neither CPU nor CPUfreq driver, i think it's
motherboard's problem cause im-sensors cann't detect any sensor,but GPU, located
in my MB

My MB is a nvidia 650i chipset, which is not as popular as another intel or
nvidia chipset, so it might not be supported well enough

i assume it will solve in next release after Fedora 9

god bless :)
Comment 8 Jarod Wilson 2008-04-03 10:34:13 EDT
Still reasonably certain this is either a bios bug or a case of a cpu that
doesn't support real cpu freq scaling, since its P4-based. For now, I'm going to
close NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.