Bug 438967 - Since updating the X11 server, some applications crash
Since updating the X11 server, some applications crash
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
8
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 05:28 EDT by jody
Modified: 2008-11-07 18:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 10:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jody 2008-03-26 05:28:04 EDT
About the component: i assume it's xorg-x11-drv-amd

After applying the newest updates, one of which was the
xorg-x11-server-1.3.0.0-44.fc8  
some applications crash upon start.
(they are applications which use openGL and stereo)
Amira4: crashes shortly after the splashscreen appears:
 [jody]:~:$/opt/Amira41-LinuxAMD64/bin/start
Using arch-LinuxAMD64-Optimize ...
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  158
  Minor opcode:  5
  Resource id:  0x43400262
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  158
  Minor opcode:  5
  Resource id:  0x0

A simple test application crashes immmediately, too:
[jody]:~:$./stest
freeglut (./stest):  ERROR:  Internal error <Visual with necessary
capabilities not found> in function fgOpenWindow
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Resource id in failed request:  0xa5
  Serial number of failed request:  15
  Current serial number in output stream:  18

Both applications worked fine immediately before i applied the update,
and crashed immediately after the update.
Comment 1 Matěj Cepl 2008-03-26 06:29:22 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

Is the stest application available (preferably in the source)? Could you please
attach it as well?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 jody 2008-03-26 08:06:20 EDT
Reinstalling the nvidia driver solved the problem.
Apprently the previous installation had no nvidia-subdirectories 
and the x11 update must have overwritten something.
Comment 3 Matěj Cepl 2008-03-26 10:16:17 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 4 Matěj Cepl 2008-03-26 10:19:27 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.