Bug 438985 - Anaconda can't find any devices to install: "No valid devices were found"
Anaconda can't find any devices to install: "No valid devices were found"
Status: CLOSED DUPLICATE of bug 436099
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Alan Cox
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 08:19 EDT by M.W.
Modified: 2008-04-26 23:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 23:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description M.W. 2008-03-26 08:19:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
I tried to install Fedora 9 Beta on a HP Compaq desktop computer. The installation runs fine until the hard drive layout menu. No devices for installation are found. If I choose any option and 'OK' the installer says 'No valid devices were found...'. The installation runs fine with Fedora 8.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Insert Fedora 9 Beta CD
2. Choose Text install
3. Continue (language, keyboard, ...) until the installation device layout menu appears.
4. Choose any option and 'OK'

Actual Results:
No installation device found

Expected Results:
A device to install should have been found.

Additional info:
# lspci -n
00:00.0 0600: 8086:2990 (rev 02)
00:02.0 0300: 8086:2992 (rev 02)
00:03.0 0780: 8086:2994 (rev 02)
00:19.0 0200: 8086:104a (rev 02)
00:1a.0 0c03: 8086:2834 (rev 02)
00:1a.1 0c03: 8086:2835 (rev 02)
00:1a.7 0c03: 8086:283a (rev 02)
00:1b.0 0403: 8086:284b (rev 02)
00:1c.0 0604: 8086:283f (rev 02)
00:1d.0 0c03: 8086:2830 (rev 02)
00:1d.1 0c03: 8086:2831 (rev 02)
00:1d.7 0c03: 8086:2836 (rev 02)
00:1e.0 0604: 8086:244e (rev f2)
00:1f.0 0601: 8086:2814 (rev 02)
00:1f.2 0101: 8086:2820 (rev 02)
Comment 1 Jeremy Katz 2008-03-26 09:46:43 EDT
What storage controller are you disks attached to?
Comment 2 M.W. 2008-03-26 09:55:48 EDT
It should be the internal SATA controller from the lspci list:

00:1f.2 IDE interface: 82801H (ICH8 Family) 4 port SATA IDE Controller (rev 02)
Comment 3 M.W. 2008-03-27 06:49:26 EDT
The product I tried it is a HP dc7700 Mini Tower. I tried today to install a HP
dc5800 with the same result. The SATA controller in the dc5800 are:

8086:2921: 82801IB (ICH9) 2 port SATA IDE Controller
8086:2926: 82801I (ICH9 Family) 2 port SATA IDE Controller
Comment 4 Chris Lumens 2008-03-27 11:12:53 EDT
If you switch to tty2 and run dmesg, are there any messages that indicate the
kernel was able to see your controller or the drives attached to it?
Comment 5 M.W. 2008-03-28 09:29:56 EDT
I think the controller is found but not the harddisk. The DVD-ROM is found.

scsi0: ata_piix
scsi1: ata_piix
ata1: SATA max UDMA/133 cmd 0x1f0 [...]
ata2: SATA max UDMA/133 cmd 0x170 [...]
ata1: SATA link down (SStatus 621 SControl 300)
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata2.00: ATAPI: HL-DT-STDVD-ROM [...]
ata2.00: configured for UDMA/100
[...]

I couldn't get the output on USB-Stick so I copied it by typing.
Comment 6 Chuck Ebbert 2008-04-02 23:57:41 EDT
Can the controller be set to AHCI mode in the BIOS?
Comment 7 Chuck Ebbert 2008-04-03 00:00:53 EDT
ata1: SATA link down (SStatus 621 SControl 300)
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)

Too bad there's no documentation for what SStatus 621 and 113 mean.
Comment 8 M.W. 2008-04-03 02:34:02 EDT
I have the following options for the SATA controller:

Multisector Transfers: 16 (Disable, 8, 16)
Transfer Mode: Max UDMA (PIO 0, Max PIO, Enhanced DMA, Ultra DMA 0, Max UDMA)
Translation Mode: Automatic (Bit Shift, LBA Assisted, User [Cylinders, Heads,
Sectors], Off)
SATA Power Management: Enable (Disable)

The values are the default factory settings. I couldn't find anything saying
"AHCI". Should I try some of the other options?
Comment 9 Chuck Ebbert 2008-04-26 23:59:24 EDT
Another instance of sleeping links... fixed in 2.6.25-6

*** This bug has been marked as a duplicate of 436099 ***

Note You need to log in before you can comment on or make changes to this bug.