Bug 438994 - pam should enforce a couple password quality checks
pam should enforce a couple password quality checks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 09:57 EDT by Steve Grubb
Modified: 2009-01-20 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:04:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2008-03-26 09:57:49 EDT
Description of problem:
1) pam should be able to ensure that a chosen password does not contain, repeat,
or reverse the associated userID.
2) pam should be able ensure that the password does not contain a configurable 
number of the same characters consecutively.
3) pam should be configurable to prevent a user from choosing a password that is
already associated with another userID. It should not tell the user that this is
the reason why the password is being rejected. It must reuse an explanation that
is already in use to reject passwords so as not to give away the reason.
Comment 2 Tomas Mraz 2008-03-26 10:06:12 EDT
1) and 2) seem reasonable and can be added to pam_cracklib.

The 3) is very security critical thing to do correctly. It will have to be
implemented very carefully in regards to timing attacks and so on. It also seems
to me as really questionable thing whether it is useful at all (apart from
giving a check on some list of items in some weird security standard).

It will also need a standalone helper for SELinux as the module itself cannot
read /etc/shadow.
Comment 3 RHEL Product and Program Management 2008-06-02 16:12:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2009-01-20 17:04:12 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0222.html

Note You need to log in before you can comment on or make changes to this bug.