Bug 438995 - Fedora 9 Beta fails to boot on Sony Vaio N250N laptop
Fedora 9 Beta fails to boot on Sony Vaio N250N laptop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 10:00 EDT by Klaatu
Modified: 2008-08-02 19:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 21:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaatu 2008-03-26 10:00:30 EDT
Description of problem:
Fedora 9 Beta does not complete boot into KDM.
The iso checksums OK, the CD verifies itself OK, but when booting on a Sony Vaio
N250N (intel core duo chip, 1gb RAM, Centrino system) the boot simply ends on a
black screen right when KDM should appear.  There are no obvious (obvious to a
noob) errors during verbose boot.

Version-Release number of selected component (if applicable):
Fedora 9, March 25th download

How reproducible:
Consistent; will not boot on Sony N250N
The Fedora 9 Alpha DOES boot.

Steps to Reproduce:
1. download iso from either torrent or server (I've done both)
2. try to boot
3. wait for KDM
  
Actual results:
Black screen.

Expected results:
Should load KDM.  I am familiar with Fedora both 8 and 9-alpha, and both work
fine on this laptop.

Additional info:
I am going to test Gnome version tonight, to see if this will boot.  I suspect
it will...if it does not I will post additional information on this bug report.
Comment 1 Rex Dieter 2008-03-26 10:45:07 EDT
What video chipset ?  (could be an X issue)
Comment 2 Klaatu 2008-03-26 10:46:56 EDT
intel 945 chipset.
Comment 3 Klaatu 2008-03-27 03:02:21 EDT
i could be doing this wrong, but for what it's worth:

i tried:
   video=vesa
as well as:
   pci=acpi

neither worked.  fyi :)
Comment 4 Ngo Than 2008-03-27 11:38:17 EDT
How does the line DISPLAYMANAGER in /etc/sysconfig/display look like?

Does it work if you change X login manager to GDM?
Comment 5 Klaatu 2008-03-27 11:54:51 EDT
An attempt to boot from the gnome version also fails in the same way; no GDM.

I am unable to see /etc/sysconfig/display as I can't get the boot procedure to
finish so that I can get into just a shell.  I will make attempts at this
tonight and post results.
Comment 6 Rex Dieter 2008-03-27 12:10:37 EDT
OK, we need to reassign this then (not a kde-specific issue), I'd guess X ?
Comment 7 Matěj Cepl 2008-03-27 12:46:51 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 Andrew Alm 2008-03-31 12:40:01 EDT
I think this is actually the backlight problem... After waiting a minute or so
with a black screen press ctrl+alt+f1 to go to a terminal.  Then press ctrl+f7
to go back to X.  For me this made GDM (in your case KDM) show up on the screen.  
Comment 9 Bug Zapper 2008-05-14 02:52:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Brennan Ashton 2008-06-07 20:58:10 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.
Comment 11 Matěj Cepl 2008-06-10 08:58:37 EDT
This shouldn't be closed, sorry about that.

Could you start computer to the runlevel 3 (in the grub put 3 in the end of the
kernel command line)? and then run startx as normal user? Will you get X working
then? If not, /var/log/Xorg.*.log would be still very interesting.

Thank you and I am sorry for the delay.
Comment 12 Matěj Cepl 2008-07-15 19:49:45 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 13 Klaatu 2008-07-15 21:08:39 EDT
The issue is fixed with the official release of Fedora 9.  If you still want to
look at /var/log/Xorg information, I can boot from beta cd and send, but
otherwise I will close this, as it now works.
Comment 14 Matěj Cepl 2008-07-16 10:44:46 EDT
No, that's of course OK -- glad it is fixed, and thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.