Bug 439003 - runlevel 3 in /etc/inittab not preventing gdm startup
Summary: runlevel 3 in /etc/inittab not preventing gdm startup
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-26 14:34 UTC by John Ellson
Modified: 2014-03-17 03:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 05:13:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2008-03-26 14:34:06 UTC
Description of problem:
Changing to runlevel 3 in /etc/inittab: 
    id:3:initdefault:
no longer stops gdm startup on reboot.

This is a major problem if trying to fix X11 problems (e.g. with the currently
borked ati driver).

Version-Release number of selected component (if applicable):
initscripts-8.60-1.x86_64
gdm-2.20.3-1.fc8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. edit /etc/inittab, change runlevel from 5 to 3
2. reboot
3.
  
Actual results:
gdm still starts (presuming X11 setup is ok, which it is not on my system)

Expected results:
console login only

Additional info:
Same problem exists in Rawhide.

Comment 1 Bill Nottingham 2008-03-26 15:20:41 UTC
Are you *SURE* this is happening on F8? Rawhide has a very different code base
that no longer reads /etc/inittab.

Comment 2 John Ellson 2008-03-26 22:13:34 UTC
99%, but I'll receck and get back to you.

So, on F9, if /etc/inittab is no longer read, why is it still there?  It only
confuses people like me who expect that it is still the way to change runlevel.

Comment 3 Bill Nottingham 2008-03-26 22:38:03 UTC
Because I haven't done a build to remove it yet. :)

Comment 4 John Ellson 2008-03-27 16:26:04 UTC
Re FC8 - I must have been mistaken, or at least, I can't reproduce it today with
latest updates.   Sorry.

So this is a F9 issue only.

Comment 5 Bill Nottingham 2008-03-27 17:28:30 UTC
OK. You can solve rawhide by editing /etc/sysconfig/init, and changing the value
of GRAPHICAL.



Comment 6 Bill Nottingham 2008-04-08 05:13:43 UTC
This has been reverted to read inittab again.


Note You need to log in before you can comment on or make changes to this bug.