Bug 439026 - Users can see channels they don't have permission to
Summary: Users can see channels they don't have permission to
Status: CLOSED DUPLICATE of bug 643403
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn400
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Sebastian Skracic
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard: US=5143
Keywords:
Depends On:
Blocks: 642708
TreeView+ depends on / blocked
 
Reported: 2008-03-26 16:03 UTC by Brandon Perkins
Modified: 2010-10-22 09:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-22 09:27:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 1 Amy Owens 2008-03-26 16:16:24 UTC
added user story and put in backlog accepted

Comment 2 Sebastian Skracic 2010-10-15 11:17:50 UTC
Description of problem:
The feature for dis-allowing users to subscribe systems to channels they dont
have permission works, but it should also disallow the user from actually seeing
the channel.

How reproducible:
Everytime

Steps to Reproduce:
1. Create a custom channel (clone it, etc)
2. Make the channel Globally Subscribable set to NO
3. Create a user
4. Make sure the user cannot see the channel under its channel permissions.
5. Login as the user and goto the Channels tab.  You should not be able to see
the custom channel.
  
Actual results:
You can see the non-globally subscribed channel.

Expected results:
Not see the non-globally subscribed channel.

Additional info:
Its likely the search tool might need to query if the user has permission to
this channel as well.

Comment 3 Sebastian Skracic 2010-10-22 09:27:05 UTC

*** This bug has been marked as a duplicate of bug 643403 ***


Note You need to log in before you can comment on or make changes to this bug.