Bug 439027 - Cannot add certificate through console GUI
Cannot add certificate through console GUI
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: Console (Show other bugs)
1.0
x86_64 Linux
medium Severity low
: 1.0
: ---
Assigned To: Andrew Wnuk
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2008-03-26 12:06 EDT by David Stutzman
Modified: 2015-01-04 18:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed fix to inability to add CA certificate through console UI (1.06 KB, text/plain)
2008-04-17 15:52 EDT, Andrew Wnuk
no flags Details
spec file diff (1.12 KB, text/plain)
2008-04-17 17:10 EDT, Andrew Wnuk
no flags Details
spec file diff (1.12 KB, text/plain)
2008-04-17 17:39 EDT, Andrew Wnuk
no flags Details

  None (edit)
Description David Stutzman 2008-03-26 12:06:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):
pki-console-ui-1.0.0-1.fc8
idm-console-framework-1.1.1-1.fc8
pki-console-1.0.0-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Open console and login to CA
2. Go to System Keys and Certificates
3. Go to CA Certificates tab and click Add
4. Click Next on first screen of Wizard
5. Select Trusted cert chain (I want to add another sub ca to the same root that
issued *this* CAs signing certificate so I can continue to use the same agent
cert for authentication as on the rest of our CAs) and click next
6. put in filename to certificate and click next
7. confirm certificate "pretty printed" on next screen and click next
8. Error is displayed
  
Actual results:
Box with the following message is displayed:
"UNKOWNEXCEPTION-java.util.MissingResourceException: Can't find resource for
bundle com.netscape.admin.certsrv.CMSAdminResources, key UNKNOWNEXCEPTION" with
OK button, after I click OK button I get another box that says "Error" in
titlebar that has no text on it and another OK button.  After clicking OK button
I am left with the "pretty printed" cert as in step 7 above.  If I click next
again I get the same error messages.

Expected results:
The cert is imported

Additional info:
Workaround: using certutil to manually import into certdb:
1. cd /var/lib/pki-ca/alias (directory depends on naming when installing)
2. certutil -A -n nickname-for-cert -t "T,c,c" -i /path/to-cert.crt -d .
Comment 1 Andrew Wnuk 2008-04-17 15:52:21 EDT
Created attachment 302791 [details]
Proposed fix to inability to add CA certificate through console UI
Comment 2 Andrew Wnuk 2008-04-17 17:10:45 EDT
Created attachment 302811 [details]
spec file diff
Comment 3 Matthew Harmsen 2008-04-17 17:26:33 EDT
attachment (id=302791) +mharmsen

attachment (id=302811) +mharmsen
Change:
+* Wed Apr 17 2008 Andrew Wnuk <awnuk@redhat.com> 1.0.0-2
to:
+* Thu Apr 17 2008 Andrew Wnuk <awnuk@redhat.com> 1.0.0-3
Comment 4 Andrew Wnuk 2008-04-17 17:39:53 EDT
Created attachment 302819 [details]
spec file diff
Comment 5 Andrew Wnuk 2008-04-17 18:00:08 EDT
svn commit pki-console.spec
Sending        pki-console.spec
Transmitting file data .
Committed revision 24.

svn commit AdminConnection.java
Sending        AdminConnection.java
Transmitting file data .
Committed revision 26.
Comment 6 Chandrasekar Kannan 2008-08-26 20:27:15 EDT
Bug already MODIFIED. setting target CS8.0 and marking screened+
Comment 7 Andrew Wnuk 2008-10-06 12:55:55 EDT
*** Bug 449856 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.