Bug 439029 - [RHEL5 U2] FireFox Tab browsing zoom is global
[RHEL5 U2] FireFox Tab browsing zoom is global
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 12:08 EDT by Jeff Burke
Modified: 2008-07-08 20:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 17:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-03-26 12:08:55 EDT
Description of problem:
 The zoom feature in Firefox(Minefield) is showing different behavior.
When tabbed pages are on like web pages if you use the zoom feature (in/out) it
sets that zomm level on all like pages.

Version-Release number of selected component (if applicable):
RHEL5.2-Client-20080320.0

How reproducible:
 Always

Steps to Reproduce:
1. Open several tabs in FireFox 
2. Tab 1 http://www.google.com/search?hl=en&q=Farm&btnG=Google+Search
3. Tab 2 http://www.google.com/search?hl=en&q=Sunlight&btnG=Google+Search
4. Tab 3 http://www.google.com/search?hl=en&q=Dogs&btnG=Google+Search
5. Tab 4 http://www.yahoo.com/
6. On Tab 1 do the following View->Zoom->Zoom In, View->Zoom->Zoom In
Notice that all the tabs that have www.google.com in them are now zoomed. The
4th tab is not zoomed.

Prior to upgrading to RHEL5.U2 the zoom options was local to the tab on like and
unlike pages.

Additional info:
Comment 1 Matěj Cepl 2008-03-26 18:22:02 EDT
Hmm, I am not sure whether this is a regression or an enhancement. ;-)

Caillon?
Comment 4 RHEL Product and Program Management 2008-07-07 09:17:48 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 Christopher Aillon 2008-07-08 17:10:57 EDT
Sorry for delayed response.  This is actually a feature.  It is not all tabs,
only all tabs from the same domain.  Theory being if one tab from the page is
not zoomed properly, other tabs from the same domain are also likely to need the
same zoom adjustments.  There is a hidden preference to fix this.  

browser.zoom.siteSpecific

We could theoretically tweak that by default to be false which would disable the
site-specific zooming, however based on feedback, and in order to stray as
little as possible from upstream, we should leave the current default.  Thus,
closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.