Bug 439038 - nethack fonts.dir file inaccessible to Xorg
nethack fonts.dir file inaccessible to Xorg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 12:49 EDT by Bruno Wolff III
Modified: 2008-03-28 09:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 09:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-03-26 12:49:55 EDT
Description of problem:
/usr/games/nethack-3.4.3/fonts/fonts.dir is labelled games_exec_t which is not
accessible from xdm_server_t.
I don't know if this is a nethack problem or an Xorg problem so I am starting it
out as an selinux problem, since you guys will know better which should be fixed.

Version-Release number of selected component (if applicable):
3.3.1-23

How reproducible:
I don't know, but I get setroubleshoot popups for this fairly often.

Steps to Reproduce:
1.I expect installing nethack and Xorg and then logging in using X is enough.
(You don't need to run nethack.)
2.
3.
  
Actual results:
setroubleshoot warnings

Expected results:
No warnings

Additional info:
Comment 1 Daniel Walsh 2008-03-28 09:40:01 EDT
Fixed the labeling in selinux-policy-3.3.25.fc9

Note You need to log in before you can comment on or make changes to this bug.