Bug 43907 - rpm core dumps while parsing nsswitch.conf (order: ldap files)
Summary: rpm core dumps while parsing nsswitch.conf (order: ldap files)
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openldap   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-07 21:33 UTC by Alex Vorobiev
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 22:01:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Vorobiev 2001-06-07 21:33:55 UTC
Description of problem:
rpm 4.0.2-8
glibc-2.2-12

/etc/nsswitch.conf:
passwd: ldap files
same for shadow and group

while installing apache 1.3.19-5, core dumps

from strace it looks like it chokes while parsing the /etc/nsswitch.conf
file

if order reversed (files ldap), the installation works fine

How reproducible:
Always

Steps to Reproduce:
1. specify ldap files order in nsswitch.conf file as above
2. try to install apache
3.
	

Additional info:

Comment 1 Jeff Johnson 2001-06-07 22:01:10 UTC
Rpm doesn't know ldap from padl, so this is a ldap problem, ...


Comment 2 Nalin Dahyabhai 2001-07-03 20:28:11 UTC
This is a rare run-in with limitations on use of dynamically-loaded modules in
statically-linked binaries.  A workaround which gets around the problem by
shunting the queries to another process is to isntall and use nscd.  At some
point we'll have a better solution for this.


Note You need to log in before you can comment on or make changes to this bug.