Bug 439089 - Code assist (or code completion) doesn't works when project shared
Code assist (or code completion) doesn't works when project shared
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
i586 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-26 17:57 EDT by Ilya Dyoshin
Modified: 2009-01-09 01:15 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 01:15:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ilya Dyoshin 2008-03-26 17:57:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv: Gecko/20080208 Fedora/ Firefox/

Description of problem:
When I shared mine project to team (via eclipse's cvs client) the code completion (code assist) stops working. This problem also happened a bit earlier with me, when I've tried to create mine project as simple import of the project. 

The problem can be "solved" until next commit to the community if I create a new C++ project. copy the files I need to it's directory structure and in the project explorer hit refresh on the project. (Importing the project doesn't helped). Than the code assist becomes working. If I share mine new code to the CVS code assist again stops working in the project. 

I'm also using the Qt Eclipse integration.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create the C++ project
2. Write code using code-assist :) (it's handy)
3. Share your project to team. 
4. Now try to run code assist. :( it's not working

Actual Results:
The code assist doesn't  works

Expected Results:
Code assist still working

Additional info:
Changing the type of C\C++ indexer doesn't helped. Changing flag values on 
- Index all files (files neither built, nor included, also) 
- Skip all references (Call Hierarchy and Search will not work)
- Skip type references (Search for type references will not work)
- Automatically update the index
- Update index immediately after every file-change 

doesn't helped also. Checked with different possibilities. 

The same behavior with code assist appears to be, if I use genuine Eclipse with CDT platform.
Comment 1 Ilya Dyoshin 2008-03-26 18:39:57 EDT
the log records when I try to run CodeCompletion (or Code assist every call it

!ENTRY org.eclipse.cdt.ui 2 0 2008-03-27 00:33:09.026
!MESSAGE The 'org.eclipse.cdt.ui.HelpCompletionProposalComputer' proposal
computer from the 'org.eclipse.cdt.ui' plug-in did not complete normally. The
extension took too long to return from the 'computeCompletionProposals()' operation.
Comment 2 Ilya Dyoshin 2008-03-26 19:06:19 EDT
now I found the crude solution. to add to the field Files to-index up-front the
/usr/include/* param... now it seems to work normally... 
Comment 3 Bug Zapper 2008-11-26 05:16:37 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 4 Bug Zapper 2009-01-09 01:15:34 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.