Bug 439091 - Graphics corruption on sis671
Graphics corruption on sis671
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 18:20 EDT by William Murray
Modified: 2008-04-09 10:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 10:39:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log from f9 beta (633.21 KB, text/plain)
2008-03-26 18:20 EDT, William Murray
no flags Details
Xorg.0.log from fedora 8 (45.65 KB, text/plain)
2008-03-26 18:22 EDT, William Murray
no flags Details

  None (edit)
Description William Murray 2008-03-26 18:20:09 EDT
Description of problem:
Display is incredibly slow, small errors abound. Probably related to incorrect
display size?

Version-Release number of selected component (if applicable):
f8.92

How reproducible:
100%

Steps to Reproduce:
1. Boot laptop, Advent 9115
2. Use NOAPIC ACPI=off to make above work
3. Thats it
  
Actual results:
Screen corrupted in small areas. Really extremely slow

Expected results:
Working fine. As in F8.

Additional info:
F9 selects 
(WW) VESA(0): Unable to estimate virtual size
(--) VESA(0): Virtual size is 1280x768 (pitch 1280)
While Kanotix found:
(II) VESA(0): Not using built-in mode "1280x768" (width too large for virtual size)
(--) VESA(0): Virtual size is 1024x768 (pitch 1024)
Comment 1 William Murray 2008-03-26 18:20:10 EDT
Created attachment 299245 [details]
Xorg.0.log from f9 beta
Comment 2 William Murray 2008-03-26 18:22:27 EDT
Created attachment 299246 [details]
Xorg.0.log from fedora 8

This uses 1280 x 768, showing that the 1280 is not a problem.
F8 graphics works fine.
Comment 3 William Murray 2008-03-31 14:49:55 EDT
Test with liveCD from Rawhidr 20080327 showed a screen roateted
by about 200 pixels right, but still slow and corrupt. Not really an
improvment!
Comment 4 Adam Jackson 2008-04-01 16:03:54 EDT
I'm impressed it works at all.

Looks like sis BIOSes are extremely unhappy with how we're doing VBE now.
Comment 5 William Murray 2008-04-03 14:13:03 EDT
Um. is that supposed to be discourging? Or does it mean someone is looking at it?
Its not good news with F9 supposed to be weeks away...
Comment 6 Adam Jackson 2008-04-09 10:39:27 EDT
It means I was looking at it.  And I even found a fix!  How cool is that.

Should be fixed in xorg-x11-server 1.4.99.901-19.

Note You need to log in before you can comment on or make changes to this bug.