This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 439103 - No wired network; WiFi only after restarting NetworkManager
No wired network; WiFi only after restarting NetworkManager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-03-26 19:58 EDT by Horst H. von Brand
Modified: 2008-06-09 13:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 13:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Result of "grep NetworkManager /var/log/messages", selected for a few days (129.37 KB, text/plain)
2008-04-01 14:48 EDT, Horst H. von Brand
no flags Details
Log for today (after updating to 0.7.0-0.9.1.svn3521.fc9) (21.96 KB, text/plain)
2008-04-01 19:26 EDT, Horst H. von Brand
no flags Details
All messages from boot to NM service restart (40.79 KB, text/plain)
2008-05-02 19:46 EDT, Didier G
no flags Details

  None (edit)
Description Horst H. von Brand 2008-03-26 19:58:31 EDT
Description of problem:
When starting up this machine connected to the wired network, that network
doesn't work and the WiFi network starts.

Trying at home (only WiFi), there is no way to get the network to work. Killing
NetworkManager and starting it again there is no network configuration, setting
the correct WiFi network gets it to connect now.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.1.svn3476.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Horst H. von Brand 2008-03-27 18:54:48 EDT
Now with kernel-2.6.25-0.161.rc7.fc9.i686 (iwl3945) NetworkManager works fine
with only WiFi.
Comment 2 Horst H. von Brand 2008-03-28 09:20:19 EDT
Make that it worked once, had to restart NM to get it to work the next time.
Comment 3 Horst H. von Brand 2008-03-28 16:04:38 EDT
Now I plugged in the wired network after using WiFi most of the day. NM never
got an IP address from DHCP. Restarting NM did not help. Stopped NM and an "ifup
eth0" got the configuration immediately.
Comment 4 Dan Williams 2008-03-31 14:18:29 EDT
Does your DHCP server require special options of any kind sent to it in the
broadcasts?  can you attach some logs from /var/log/messages showing the NM log
output?  Thanks!
Comment 5 Horst H. von Brand 2008-04-01 14:48:21 EDT
Created attachment 299943 [details]
Result of "grep NetworkManager /var/log/messages", selected for a few days

My DHCP server at home (entries in the file after around 18:00 or on weekends)
is a Linksys wrt54g, with Linksys firmware and no special setup. Here at work
it is the same for WiFi, and a CentOS 4 box with bog-standard DHCP server setup
for eth0.

March 29, 30 was a weekend, all te results at home.
March 31 in the morning (7:40 or so) I was trying to get a network
(unsuccessfully) away from here. No idea of the setup over at that place.
Around 10:30 I came to work. The wired network did /not/ work, whatever the log
says. I tried several times via NM's GUI, no avail.

The wired network doesn't work at all, I have to disable NM and "ifup eth0" by
hand.
Comment 6 Horst H. von Brand 2008-04-01 19:26:02 EDT
Created attachment 299991 [details]
Log for today (after updating to 0.7.0-0.9.1.svn3521.fc9)

After updating today at home (only WiFi, Linksys wrt54g). On boot, no network;
restarted NM, no network again, nothing on the GUI menu. Asked for new network
linksys, nothing; tried again, succeeded.

BTW, "Auto linksys" appears 3 times on the menu after start.
Comment 7 Horst H. von Brand 2008-04-02 11:26:40 EDT
NetworkManager-0.7.0-0.9.1.svn3521.fc9.i386

I hate this...

The WiFi network (no wire) away from here worked for the very first time (unless
at home, it has a password; I had tried to get on to it occasionally only,
so...). I updated over there, now at work on boot the wired network started
fine. Still need to see what happens today at home, and give it a few tries, but
it looks fixed.

Thanks!
Comment 8 Horst H. von Brand 2008-04-02 11:30:40 EDT
On second thoughts...

After today's update X wouldn't start at all, so I had to forcefully downdate
xorg-x11-server-Xorg. The above is after all this. I don't think the delay could
influence things that much, but...
Comment 9 Horst H. von Brand 2008-04-02 19:07:06 EDT
OK, at home (only WiFi, X now starts OK) had to restart NM to get the network to
work.
Comment 10 Horst H. von Brand 2008-04-03 22:02:04 EDT
Today (at home, just WiFi) the network started just fine. So this looks like
half and half.
Comment 11 Dan Williams 2008-04-04 14:06:58 EDT
What do the ifcfg files in /etc/sysconfig/network-scripts/ look like for your
wired cards?  Do any of them have NM_CONTROLLED=no in them?
Comment 12 Horst H. von Brand 2008-04-04 20:07:15 EDT
No mention of NM_CONTROLLED in any /etc/sysconfig/network-scripts/ifcfg-*

BTW, today the wired network started fine at work.

Just now at home, WiFi didn't start, I had to restart NM and then it got the
network immediately.

I had a bunch of ifcfg-*.bak files, just deleted all of them.

ifcfg-eth0 (only Eth here) is just:

# Intel Corporation 82573L Gigabit Ethernet Controller
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=00:A0:D1:78:D7:C5
Comment 13 Dan Williams 2008-04-10 12:29:16 EDT
Is your wifi an iwl3945 or iwl4965 by chance?  you may be hitting a scanning bug
in the driver.

Can you grab latest kernel updates and latest NM from koji and see if the
problem still exists?
Comment 14 Horst H. von Brand 2008-04-11 09:25:12 EDT
iwl3945, kernel-2.6.25-0.218.rc8.git7.fc9.i686,
NetworkManager-0.7.0-0.9.1.svn3549.fc9.i386 (yesterday's updates; also latest in
koji). Network at home (just WiFi) worked fine, today at work (wired + WiFi)
only WiFi, after restarting NM I get the wired network and a while after that it
announces I'm connected to "wireless network (none)" (?), the GUI tells me
(correctly) that I'm connected to our internal WiFi network too.
Comment 15 Horst H. von Brand 2008-04-12 15:12:47 EDT
Same setup as before, at home (only WiFi). NM showed my network, but no
connection. Clicking on that, 3 times "auto linksys". No dice, restarted NM and
got network immediately.
Comment 16 Adrian "Adi1981" P. 2008-04-15 11:41:50 EDT
i've got iwl4965 and got the same issue - after starting system i must restart
NM so that he could find wifi networks. Without restart it's not possible to
find any network. Tested on 2 different wifi networks. I will check later with
.231 kernel if it'll be still the same.
Comment 17 Horst H. von Brand 2008-04-20 14:14:49 EDT
Tried kernel-2.6.25-1.fc9.i686, NetworkManager-0.7.0-0.9.2.svn3566.fc9.i386. As
comment #15, just had to restart NM 2 times to get network at home. Wired
network usually requires restarting NM too.
Comment 18 Didier G 2008-04-25 05:06:30 EDT
I have the same problem on a fresh installation and I have to restart NM to get
it working and have applet displayed in tray.

This is that I get when I loggin :

# /sbin/service network status
Périphériques configurés : 
lo eth0
Périphériques actuellement actifs : 
lo eth0

# /sbin/service NetworkManager status
NetworkManager est mort mais subsys est verrouillé

(--> NetworkManager is dead but subsys is locked)

# /sbin/service NetworkManagerDispatcher status
NetworkManagerDispatcher (pid 2072) en cours d'exécution...

# nm-tool

** (process:2607): WARNING **: nm_object_get_property: Error getting
'WirelessHardwareEnabled' for /org/freedesktop/NetworkManager: The name
org.freedesktop.NetworkManager was not provided by any .service files

NetworkManager Tool

State: unknown

NetworkManager appears not to be running (could not get its state).

# /sbin/service NetworkManager restart
Arrêt du démon NetworkManager :                            [ÉCHOUÉ]
Configuration des paramètres réseau...
Démarrage du démon NetworkManager :                        [  OK  ]

# /sbin/service NetworkManager restart
Arrêt du démon NetworkManager :                            [  OK  ]
Configuration des paramètres réseau...
Démarrage du démon NetworkManager :                        [  OK  ]
Comment 19 Didier G 2008-05-02 06:51:16 EDT
I installed today update to NetworkManager-0.7.0-0.9.3.svn3623 and I still have
problem. I must restart service to get wired connection :

$ sudo nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            pcnet32
  State:             unavailable
  HW Address:        08:00:27:70:60:CB

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings

$ sudo /sbin/service NetworkManager restart
Arrêt du démon NetworkManager :                            [  OK  ]
Configuration des paramètres réseau...                     [  OK  ]
Démarrage du démon NetworkManager :                        [  OK  ]
$ sudo nm-tool

NetworkManager Tool

State: connected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            pcnet32
  State:             connected
  HW Address:        08:00:27:70:60:CB

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings

  IP Settings:
    IP Address:      10.0.2.15
    Subnet Mask:     255.255.255.0
    Broadcast:       10.0.2.255
    Gateway:         10.0.2.2
    DNS:             10.0.2.3
Comment 20 Dan Williams 2008-05-02 10:41:48 EDT
didier: could you attach the /var/log/messages file right after boot up, but
_before_ restarting the service?  Thanks!
Comment 21 Didier G 2008-05-02 19:46:49 EDT
Created attachment 304433 [details]
All messages from boot to NM service restart
Comment 22 Horst H. von Brand 2008-05-05 16:56:25 EDT
Now (NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386) WiFi starts OK every time, but
to get the wired network I have to restart NM by hand. It then takes a while and
gets the wired network (and later the wireless '(none)' (?!))
Comment 23 John Poelstra 2008-05-07 12:59:10 EDT
I've seen this same problem.

In my scenario NetworkManager was working fine in Fedora 8.  After doing an
anaconda upgrade to F9 PR the wired network does not automatically connect if it
is present at laptop boot time.  What is strange is that watching bootup eth0
(wired ethernet) gets an address and sets the host name, but when NetworkManager
finally starts it takes over and starts the wireless network and switches to it
instead.

Clicking on the icon in the panel it is not possible to manually select and
change to eth0 because it is grayed out.

The only thing I've found that corrects the situation is to physically remove
the cable and plug in again after logging into the desktop.  After this both the
eth0 and wireless are noted as being selected and it is now possible to manually
switch back and forth between eth0 and wireless.

Here is  ifcfg-eth0:

# Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile)
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:11:25:86:B0:B0
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
NM_CONTROLLED=yes 
Comment 24 John Poelstra 2008-05-07 14:24:00 EDT
Another data point as suggested by f13....

As an upgrade from F8 the 'network' service had previously been enabled for the
standard runlevels.  

I completely disabled the 'network' service it and now when cable is connected
at boot it connects, as does the wireless.  Just doing a simple look around with
'iftop' it appears all traffic is going over eth0 even though the panel applet
shows both connected.  This is also confirmed by 'ifconfig'.

Forgive me if if i'm hijacking this bug and should create a separate one for
this issue--just let me know and I'll do it.
Comment 25 Dan Williams 2008-05-08 14:32:47 EDT
John: there was a race condition in the preview release that caused some wired
devices not to be enabled when NM started up.  Can you re-test with latest
rawhide or the F9 RC?  Just a "yum upgrade NetworkManager*" should do it too. 
You want at least svn3623.
Comment 26 John Poelstra 2008-05-08 19:05:29 EDT
Here is what I'm running:

$ rpm -qa | grep Network | sort
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-glib-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc9.i386

Notebook is an IBM T41 Thinkpad
Comment 27 Bug Zapper 2008-05-14 02:54:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 28 Fujisan 2008-05-14 09:17:51 EDT
I upgraded this morning from F8 to F9 with preupgrade and almost everything went
ok except for NetworkManager. When I boot my laptop with the cable connected to
it, I see in the log it is starting the network but then when i log in, i am not
connected. The only easy thing I do to get reconnected with NM is I unplug and
replug the cable. NM detects it and the network card gets an IP through dhcp.
If I reboot and login again, the network card is disconnected.


Linux tosca.opera.univ-pau.fr 2.6.25-14.fc9.i686 #1 SMP Thu May 1 06:28:41 EDT
2008 i686 i686 i386 GNU/Linux

# Broadcom Corporation BCM4401-B0 100Base-TX
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:15:C5:53:FD:F5
ONBOOT=yes
TYPE=Ethernet
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
NM_CONTROLLED=yes

NetworkManager-glib-devel-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-devel-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-glib-0.7.0-0.9.3.svn3623.fc9.i386
Comment 29 quintesse 2008-05-15 08:05:28 EDT
Just a comment: after a fresh install of F9 the NM applet just refused to let me
connect, only by doing an 'ifup eth0' could I get things to work but NM would
still think I was disconnected. Which in itself is already bothersome enough
weren't it for the fact it seems that several programs now actively rely on the
NM to tell them that they are connected or not, so I couldn't even update the
packages on my system using the GUI tools (three cheers for the command line).

Only reading here that there is an option NM_CONTROLLED finally fixed things for
me. The moment I changed it the NM noticed, told me my system was on-line (which
it was all the time of course) and all was fine.

Just think it is a lousy "first experience".

Why can't the NM at least detect that there are other connections that it
doesn't manage and give you some information? Or give you the option to switch
from managed to unmanaged and vise-versa. Anything.
Comment 30 Ingvar Hagelund 2008-05-25 05:07:01 EDT
I wanted to switch to NetworkManager, even for a fixed ip-address, to get easy
VPN configuration and operation. I found that to get access to get my vpn
connections active, I had to restart NetworkManager.

After a bit debugging, I found that I had to disable the network service
(chkconfig network off), and add NM_CONTROLLED to the ifcfg script of the
interface (via system-config-network). Then it worked more or less as I want,
except that the interface is not up'ed at boot time.

Now, I would like to know: Is it not possible to get a "normal" cabled
interfaced (fixed ip or dhcp) up'ed at boot time, and still control interfaces
or services (aliases, VPN, whatever) that depends on that device via the NM-applet?

My workstation has a few servers and runs an ntpd client. These of course does
not work unless the primary NIC gets up'ed at boot time.
Comment 31 Stepan Lendak 2008-05-31 08:59:29 EDT
yes, solution from Ingvar Hagelund works perfect.
Comment 32 Horst H. von Brand 2008-06-01 19:14:39 EDT
Now (NetworkManager-0.7.0-0.9.3.svn3675.fc10.i386,
kernel-2.6.26-0.45.rc4.git2.fc10.i686 on rawhide) it works fine. It has for a
while, but as the problem was intermittent (and firefox just hangs when
accessing here) I didn't report it sooner.

Service network is on.
Comment 33 Dan Williams 2008-06-02 17:09:11 EDT
Ingvar: NM should be starting around #27 which should be before ntpd or anything
that really depends on network.  So if you have the interface's ifcfg file set 
up and NM_CONTROLLED=yes for it, then it should work and the interface should be
brought up by NM.  Since NM brings the network up in the background though, if
startup is fast enough, it may not be up by the time ntpd starts.  In that case,
you'll want to add NETWORKWAIT=yes to block for 10s.
Comment 34 Ingvar Hagelund 2008-06-02 17:18:43 EDT
Aha. My started at #99. An upgrade "bug" from earlier fedora version, perhaps?

# chkconfig NetworkManager off; chkconfig NetworkManager on

Running this fixed the sequence number. I'll post back the next time I reboot.

Ingvar


Comment 35 Dan Williams 2008-06-02 17:32:47 EDT
I don't think the F9-GOLD version of NM's RPM included:

chkconfig NetworkManager resetpriorities

in the %post, but subsequent versions in updates-testing do that.  In the end,
you may need this sequence:

chkconfig haldaemon resetpriorities
chkconfig NetworkManager resetpriorities

to move NM up since NM depends on haldaemon, and if haldaemon isn't earlier then
NM won't be earlier either.
Comment 36 Bill C. Riemers 2008-06-05 05:09:38 EDT
I am seeing a similar type problem.  After installing Fedora 9 my network failed
to start automatically.   NetworkManager showed the two Wired connections, both
marked as "never", and not started.

Manually running:

service network restart

starts the network normally.

After investigating, I found that neither of my wired network connections were
marked as controlled by NetworkManager.  I marked both connections as managed by
network manager, and manually entered the Mac address into NetworkManager.

After that, NetworkManager was able to start connection 1, but not connection 2.
 Since I am not using wireless, I finally decided just to use the good old
"network" init.d script, and to disable NetworkManager.

So the two features I could not get to work with NetworkManager:
  1. For NetworkManager to work automatically post install.
  2. Multicasting with DHCP and a static address.
  3. Both IPV6 and IPV4 enabled.
 
Here is my networking-script configurations that work with "network" but I can't
get to work with NetworkManager:

[root@localhost network-scripts]# grep -v DNS1 ifcfg-eth0 | grep -v SEARCH
# Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:19:b9:11:5e:e2
IPV6INIT=yes
IPV6_AUTOCONF=yes
ONBOOT=yes
NM_CONTROLLED=no
TYPE=Ethernet
USERCTL=yes
PEERDNS=yes

[root@localhost network-scripts]# grep -v DNS1 ifcfg-eth0:1 |grep -v SEARCH
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth0:1
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=192.168.2.201
USERCTL=yes
PEERDNS=yes
IPV6INIT=no
ONPARENT=yes
NM_CONTROLLED=no

Comment 37 Bill C. Riemers 2008-06-05 05:20:20 EDT
See related bug #443968
Comment 38 Bill C. Riemers 2008-06-05 05:31:11 EDT
See related bug #450088
Comment 39 Ingvar Hagelund 2008-06-07 09:21:35 EDT
I had to reset priorities on NetworkManager, haldaemon and messagebus. Then the
interfaces worked as expected.

Ingvar
Comment 40 Dan Williams 2008-06-09 13:22:42 EDT
Ugh.  Ok, NM updates in updates-testing will reset the priorities of NM itself,
and I think messagebus does this by default as well.  Not sure about hal though
it should probably do that too if it doesn't already.

Note You need to log in before you can comment on or make changes to this bug.