Bug 439107 - Cant configure network interface post kernel update
Cant configure network interface post kernel update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 449841
  Show dependency treegraph
 
Reported: 2008-03-26 20:55 EDT by Tony
Modified: 2008-06-21 19:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 19:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bootlog eth0 configured with IP (36.88 KB, text/plain)
2008-04-24 23:46 EDT, Tony
no flags Details
bootlog etho configured to use dhcp (41.33 KB, text/plain)
2008-04-24 23:46 EDT, Tony
no flags Details

  None (edit)
Description Tony 2008-03-26 20:55:43 EDT
Description of problem:I had a fully functioning laptop (aspire 5020, AMD64, ATI
Radeon Graphics). At some stage an update stopped the network from working. It
no longer recognises my RTL 8169 NIC and assigns the BroadCom Wlan nic as eth0.
No matter what I do with the Network Configuration tool I can't get this to
change. I think the problem lies with Kernel 24.3-34


With Kernel 23.1-42 it was working (but I cant go back to that as the X server
wont start)


Version-Release number of selected component (if applicable):


How reproducible: On every boot


Steps to Reproduce:
1.Boot the computer
2.
3.
  
Actual results:
No functional network available

Expected results:
Should be connected the network

Additional info:
Comment 1 Tony 2008-03-26 21:54:39 EDT
Update. Managed to update the kernel to 24.3-50 (CLI in Kernel 23.1-42).
Slight improvement it now recognises the RTL 8169 NIC. I can now set eth0 and
wlan0 up in Network Configuration but cant get them to activate.
Note. under the Hardware tab the status is shown as 'system' instead of 'ok'
Comment 2 Tony 2008-03-29 01:06:53 EDT
I've done a completely fresh install of F8. Networking functions right out of
the box (and I've got X working as vesa). Yum update all (kernel 24.3-50)
network configuration tool shows exactly the same config as kernel 23.1-42 but
cant start the network.
Comment 3 Tony 2008-04-02 17:31:15 EDT
Installed kernel 24.4-64 today. Issue is still unresolved
Comment 4 Steever 2008-04-04 23:19:46 EDT
I have the same problem with the same notebook.  Also experience same problem
with beta of Fedora 9.
Comment 5 Tony 2008-04-24 23:46:04 EDT
Created attachment 303727 [details]
bootlog eth0 configured with IP
Comment 6 Tony 2008-04-24 23:46:59 EDT
Created attachment 303728 [details]
bootlog etho configured to use dhcp
Comment 7 Tony 2008-04-24 23:57:23 EDT
This should have been before the attachments but I didn't save before creating them.
I did not mention previously that attempts to start the network would cause the
computer to lock up (no response to inputs, display frozen).
I've done some more testing with the latest network package updates. It seems
that the network is starting up but the computer interfaces are frozen (script
stuck in a loop?). I've attached some boot logs so that you can see whats happening.
Comment 8 Tony 2008-04-25 00:03:03 EDT
I should mention that eth0 is not set to start on boot. The network start is manual.
Comment 9 Tony 2008-04-30 01:13:33 EDT
Updated to kernel 2.6.24.5-85 today. Same problem, activate eth0 computer locks up.
Comment 10 Michal Hlavinka 2008-05-07 11:19:32 EDT
I have the same problem.

HW: Asus A6T, 64 bit, ethernet RTL 8169 
kernel 2.6.23.1-42 is working fine
kernel 2.6.24.* is not working at all

I had the same problem in F9 with 2.6.24.* kernels, but 2.6.25 in F9 is 
working fine
Comment 11 Tony 2008-05-09 00:43:56 EDT
I've just installed rawhide and cant get a functioning desktop. It would appear
that it does not try to start the network until you log in. In F 8 it started on
boot so I could set it to not load on boot and at least get a desktop now its
handled by the  network manager to start when you log in so as soon as you do
you get various errors. The nature of this problem has changed so much since I
raised the bug report that I'm going to submit a new one.
Comment 12 Tony 2008-05-09 03:41:58 EDT
One last go at fixing this has worked. Start up in a text console, edit
/etc/sysconfig/network-scripts/ifcfg-eth0 make ONBOOT and NM_CONTOLLED = no(this
stops the system from strating the network). Boot the comp, when you have a
desktop remove Network manager and dispather from services then reboot. Using
the network configuration tool assign ip address , net mask, gateway and dns and
start the network. Now downloading 104 updates.
Comment 13 Tony 2008-06-21 19:01:02 EDT
Fedora 9 with nohz=off has fixed this.

Note You need to log in before you can comment on or make changes to this bug.