Bug 439137 - PS3 fails booting with non-LVM root filesystem
PS3 fails booting with non-LVM root filesystem
Status: CLOSED DUPLICATE of bug 389331
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 04:48 EDT by Kazunori Asayama
Modified: 2008-04-08 22:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 22:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2008-03-27 04:48:08 EDT
Description of problem:

The PLAYSTATION 3 fails booting when:

  - root partition is located on the internal hard disk drive and,
  - the root partition is *NOT* an LVM,

because:

  - initrd doesn't contain PS3 specific storage drivers,
    i.e. ps3stor_lib, ps3disk, and,
  - mkrootdev command of nash (maybe) can't handle the PS3 disk device (/dev/ps3d*)

Version-Release number of selected component (if applicable):

  mkinitrd-6.0.39-1.fc9.ppc (F9 Beta)

How reproducible:

  Every time.

Steps to Reproduce:

1. Insert F9 Beta install DVD into PS3.
2. Run installer in text mode (PS3 doesn't have enough memory for GUI installer).
3. Choose 'Create custom layout' in 'Partitioning Type', and create the root
partition on /dev/ps3da in 'Partitioning' page.
4. Choose 'Customize software selection' in 'Package selection' page, and
disable 'Hardware Support' in the 'Package Group Selection' page (to avoid
anaconda's problem #437993).
5. Finish installation and reboot.

Actual results:

(quiet option is disabled)

...
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Mount failed for selinuxfs on /selinux: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Booting has failed.

Expected results:

PS3 can mount the root filesystem on /dev/ps3d*.

Additional info:

If the root partition is an LVM, PS3 can boot normally.

By adding the PS3 specific storage drivers to the initrd, and modifying
"root=" kernel option to specify the root device explicitly
(e.g. "root=/dev/ps3da1") by hand, PS3 becomes to be able to boot.
Comment 1 Kazunori Asayama 2008-03-28 07:44:25 EDT
It looked like that this problem had the same cause, so I tried the fix for F8
attached to the Bug #389331 then it also resolved this problem in rawhide.
Comment 2 Kazunori Asayama 2008-04-08 22:18:57 EDT

*** This bug has been marked as a duplicate of 389331 ***

Note You need to log in before you can comment on or make changes to this bug.