This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 439159 - [RFE] Conversion of embedded objects of convertable types is default disabled
[RFE] Conversion of embedded objects of convertable types is default disabled
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 08:19 EDT by Hans de Goede
Modified: 2009-01-05 04:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 04:36:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file displaying the problem (627.00 KB, application/octet-stream)
2008-03-27 08:19 EDT, Hans de Goede
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 97319 None None None Never

  None (edit)
Description Hans de Goede 2008-03-27 08:19:04 EDT
Description of problem:
-open the attached file
-double click one of the large text areas for example the one which has
 "Onderwerpen: datastructuren en algoritmen" in it (its Dutch, sorry)
-it opens in ooo-writer, but as read-only

Expected results
-being able to edit the embedded word object, this used to work as as I can 
 remember.

This is with version: 2.4.0-12.1.fc9
Comment 1 Hans de Goede 2008-03-27 08:19:04 EDT
Created attachment 299308 [details]
file displaying the problem
Comment 2 Caolan McNamara 2008-03-27 10:27:59 EDT
Were you able to edit it inline in the past, i.e. a new window was not opened. 

Perhaps this is the "convert embedded objects" option, i.e.
tools->options->load/save->microsoft office and at least toggle the [L] for
autoconvert embedded word to embedded writer option on.

Checking with stock F-8 I see no change in behaviour in F-9 wrt. this, but in
both cases toggling the convert on load should give an inline editable converted
object.
Comment 3 Hans de Goede 2008-03-27 11:18:35 EDT
Ah, yes much better!

I reinstalled my machine sometime ago and lost those settings (which I had
applied earlier to be able to edit formulas embedded in presentations)

Why are these off by default? I would like to advocate turning them on by default.

I think this can be closed as "not a bug", but why does double clicking with
these options off open the embedded objects in writer at all, I can already see
them fine in the ooo-calc view, so opening a read only copy in a separate writer
window seems pretty useless (and confusing).

It would be much better do disallow editing completely when these options are
off and throw a dialog explaining about these options when one double clicks.

I know this should probably be taken upstream, but upstream's bugtracker is a
nightmere for mere mortals like me (too many components, etc.).
Comment 4 Caolan McNamara 2008-03-27 11:36:02 EDT
Its off by default (in the vanilla version and fedora) because the conversion is
*slow*, and there can often be a lot of embedded objects in a document
(especially with equation editor), and the conversion is done during the load
not on demand. So you get the occasional massive load times for a simple document.

You can't edit them as an unconverted "native" ole2 object because what you see
on screen is actually just the wmf preview image that is in all ole2 objects,
its just a vector picture.

What we *should* do is convert objects on demand when they are activated and of
a type we know how to convert and not at load time that way we get them editable
without the load-time performance hit
Comment 5 Jon Stanley 2008-04-23 16:30:47 EDT
Adding FutureFeature keyword to RFE's.
Comment 6 Caolan McNamara 2009-01-05 04:35:58 EST
Moving upstream under http://www.openoffice.org/issues/show_bug.cgi?id=97319

Note You need to log in before you can comment on or make changes to this bug.