This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 43917 - RFE: Preserving RAID partitions on full install
RFE: Preserving RAID partitions on full install
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 21:56 EDT by Alexandre Oliva
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2001-06-07 21:56:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9)
Gecko/20010507

Description of problem:
I have a machine with a few RAID filesystems that I'd like to preserve
across a new full install (not upgrade).
Currently, what I have to do is to leave the RAID partitions unused, and
set them up in /etc/raidtab and /etc/fstab after the installation is completed.
What I'd like to be able to do is to tell disk druid to load a pre-existing
raidtab from somewhere (say /boot/raidtab, where I keep a copy of
/etc/raidtab), so that I'd be able to tell the installer where to mount
these partitions (extra bonus for loading /etc/fstab from somewhere too :-)
and get the box ready to go at the first boot.

How reproducible:
Always

Steps to Reproduce:
1.Install the system and create a couple of RAID/ext2 filesystems.
2.Decide to re-install it, willing to preserve the existing RAID filesystems.
3.Have to introduce the raid devices only after the full installation,
because disk druid says creating the raid devices will clobber the existing
data in those partitions.
	

Actual Results:  The system won't have the RAID filesystems on the first
boot, and they have to be configured in /etc/fstab and /etc/raidtab manually.

Expected Results:  Have the installer read raidtab from the previous
installation or from some other place so as to preserve the information
across the re-install.

Additional info:

It may be that I could create the raid devices, and just tell the installer
to preserve those filesystems, but I didn't have the guts to try it.
Comment 1 Brent Fox 2001-06-12 12:00:10 EDT
This is an interesting idea.  Assigning to msw as it is related to his work on
partitioning.
Comment 2 Matt Wilson 2001-07-20 09:51:45 EDT
msf was working on this
Comment 3 Michael Fulbright 2001-07-27 16:29:23 EDT
Will attempt to address in the future.
Comment 4 Michael Fulbright 2002-03-26 12:25:34 EST
Deferred to future release.
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.