Bug 439175 - Volume groups not found on virtual block device
Volume groups not found on virtual block device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-27 09:42 EDT by Dennis Jacobfeuerborn
Modified: 2008-04-03 14:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 14:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixed virtio block device patch (509 bytes, patch)
2008-04-02 14:55 EDT, Daniel Berrange
no flags Details | Diff
Fix clvmd compilation (405 bytes, patch)
2008-04-02 14:56 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Dennis Jacobfeuerborn 2008-03-27 09:42:29 EDT
I'm trying to boot a F9 beta image as guest using "if=virtio". I built a new
initrd inside the guest to include the virtio drivers an on boot the kernel
detects vda1 and vda2 correctly but then fails to find any volume groups.
Booting the image with the regular "media=disk" works fine.
Comment 1 Dave Wysochanski 2008-04-01 15:03:56 EDT
Could someone from the virtualization team look at this?
Comment 2 Dave Wysochanski 2008-04-01 15:05:44 EDT
Did this fix your problem?
http://www.mail-archive.com/kvm-devel@lists.sourceforge.net/msg14499.html
Comment 3 Daniel Berrange 2008-04-01 15:12:59 EDT
Could it be that  vgscan is not considering  'vda*' devices as possible physical
volumes ?
Comment 4 Dennis Jacobfeuerborn 2008-04-01 15:21:59 EDT
(In reply to comment #2)
> Did this fix your problem?
> http://www.mail-archive.com/kvm-devel@lists.sourceforge.net/msg14499.html

That was my initial problem but after rebuilding the initrd the kernel found the
virtual devices (vda1 and vda2) but now it still doesn't find the volume group.
Comment 5 Dennis Jacobfeuerborn 2008-04-01 16:19:13 EDT
Ok, I tweaked the initrd and added a "-vvv" to the vgscan which reveals the
following:

"/dev/vda2: Skipping: Unrecognized LVM device type 252"
Comment 6 Daniel Berrange 2008-04-01 16:29:27 EDT
What version of the lvm2 RPM do you have - this should have been fixed a short
while ago according to the changelogs:


* Wed Mar  5 2008 Jeremy Katz <katzj@redhat.com> - 2.02.33-10
- recognize vio disks

Comment 7 Dennis Jacobfeuerborn 2008-04-01 16:54:12 EDT
The latest version in rawhide is lvm2-2.02.33-9.fc9.i386.
According to koji 2.02.33-10 never made it there:
http://koji.fedoraproject.org/koji/packageinfo?packageID=221
Comment 8 Daniel Berrange 2008-04-01 17:02:37 EDT
Looks like Jeremy forgot to request the build after committing to CVS...
Comment 9 Dennis Jacobfeuerborn 2008-04-01 19:31:44 EDT
I rebuilt the lvm2 package with the sources from CVS
(sources.redhat.com:/cvs/lvm2), installed it on the guest and rebuilt the initrd
but the boot still fails with the same error.
Comment 10 Daniel Berrange 2008-04-02 14:55:30 EDT
Created attachment 300114 [details]
Fixed virtio block device patch

The current patch for virtio in cvs is broken. This fixes it. With this applied
i can successfully run	'pvcreate /dev/vda'
Comment 11 Daniel Berrange 2008-04-02 14:56:30 EDT
Created attachment 300115 [details]
Fix clvmd compilation

Oh and the lvm2 package does not actually compile under rawhide. It is missing
a #include <limits.h> in the clvmd.c file. This patch fixes that brokenness too
Comment 12 Daniel Berrange 2008-04-02 14:58:11 EDT
It appears that commits to the LVM package are restricted in Fedora, so someone
else will have to apply these and do a build...
Comment 13 Dennis Jacobfeuerborn 2008-04-02 18:31:15 EDT
With the two patches applied the guest now boots properly except for the
following error:

Mounting local filesystems:  mount: special device
UUID=cd7b36bf-1578-44dd-857c-9a8a9c515580 does not exist

The fstab entry looks like this:
UUID=cd7b36bf-1578-44dd-857c-9a8a9c515580 /boot ext3 defaults 1 2

When I log in and try the respective command from rc.sysinit "mount -a -t
nonfs,nfs4,smbfs,ncpfs,cifs,gfs,gfs2 -O no_netdev" I don't get this error and
/boot is mounted properly.
Comment 14 Jeremy Katz 2008-04-02 23:23:53 EDT
Thanks Dan, applied both (insert grumble about device name changing here) and
building

Dennis -- the latter like a separate problem and should probably be filed separately
Comment 15 Jesse Keating 2008-04-03 14:38:55 EDT
Closing this rawhide as Dennis already tested with the patches and had success.

Note You need to log in before you can comment on or make changes to this bug.