Bug 43918 - Entering password for new user is confusing
Entering password for new user is confusing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 21:59 EDT by Peter H. Jones
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 21:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2001-06-07 21:59:28 EDT
Description of Problem: While creating a new user in linuxconf under gnome, a Change Password window appears. If an unacceptable 
password is typed (too short, dictionary word, ...), an appropriate message, then the user is asked to retype his password. No further
password prompts appear, but user cannot log in. Logging in as root and doing an "su" allows logging in under the new userid, but
the passwd command demands the previous password, which is unknown.

The only simple way out is to use the Password button at the bottom of the user account creation/editing screen. Unfortunately, this
button is hidden among others, and its position on the screen in not related to the New Password dialogue above. 

How Reproducible:
Create a new user, attempt to give inadequate password when prompted.

Steps to Reproduce:
1. As root, start linuxconf under Gnome
2. Select Users, .... Create
3. Create user account, observe prompt messages when user password is needed
4. Observe unrelated placement of "New Passwsord" dialogue, and "password" button in
    linuxconf user-creation dialogue     

Actual Results:
1. Message asking for user password doesn't give its requirements until user fails to meet then.
2. Password window asks for a repeat, even if first attempt was invalid.
3. No further password dialogue, although user can't log in.

Expected Results:
1. Clearer menu design in linuxconf when creating user accounts. Password dialogue should
    grow out of user creating dialogue.

Additional Information:
Comment 1 Brent Fox 2002-06-04 23:38:43 EDT
Closing since we don't ship linuxconf anymore.

Note You need to log in before you can comment on or make changes to this bug.