Bug 439188 - Anaconda takes 100% Cpu and works extreme slow
Anaconda takes 100% Cpu and works extreme slow
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 10:13 EDT by Thomas Janssen
Modified: 2009-02-06 09:39 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 09:39:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Janssen 2008-03-27 10:13:57 EDT
Description of problem:
I try to install Fedora 9beta into a virtual machine (VirtualBox 1.5.6). My Host
System is Fedora 8 on a Fujitsu-Siemens Laptop K7600 Series. Cpu Amd 2500
Mobile, RAM 786 MB. When i start the installation, the cpu usage goes up to 100%
(normal at this stage). The installation "runs" until it reaches the step:
'running /sbin/loader' from that point, the cpu usage stays at 100% and it takes
about 2 hours until it reaches the first graphical screen.
The same behavior was with Fedora 9alpha, which was not installable at all.
Thats why i filed this bug under anaconda and not the kernel.
Fedora 8 unity re-spin installation works like a charm with same Vbox 1.5.6.
I have tried every set of settings inside Vbox as possible, but no change. I
tried forceing i586 with no change.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.55-1.i386

How reproducible:
Every try to install F9beta into Vbox 1.5.6 (latest)

Steps to Reproduce:
1. Start Vbox
2. Start the F9beta machine
3. wait until it reaches the step: running /sbin/loader
  
Actual results:
Nearly overheating Laptop, where you cant really do anything in the meanwhile.

Expected results:
Installation with a "normal" use of CPU-Power and able to work in the meantime.
Like a Fedora 8 installation in Vbox.

Additional info:
Comment 1 Chris Lumens 2008-03-27 11:09:13 EDT
Are there any helpful error messages on tty3 or tty4?
Comment 2 Jóhann B. Guðmundsson 2008-03-27 12:43:56 EDT
linux text nohz=off noapic noacpi  nopcmcia selinux=0 seemed to do the trick 
for him.

I asked to try all the variants of these switches, doubt that all of 
these are needed..

He can install http://fedoraunity.org/fedora-8-re-spin-20080204-released

But not FC9 alpha nor F9 beta

Dont know if this is related to "Backported fix for i586 from development"
in the respin or some other AMD problem
Comment 3 Dave Jones 2008-03-27 13:16:57 EDT
it's the page allocation debugging.  It's incredibly slow when run in virtual
machines.  It'll be turned off soon.
Comment 4 Jóhann B. Guðmundsson 2008-03-27 13:43:03 EDT
He just reported that the minimum kernel-p to be able to install
fc9beta are noapic noacpi nopcmcia 
Comment 5 Thomas Janssen 2008-03-27 16:02:15 EDT
Thanks Dave Jones, that`s what i was searching for. And thanks to johannbg for
assistance @ #fedora.
Comment 6 Bug Zapper 2008-05-14 04:19:12 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.