Bug 439213 - clock's timezone-guessing heuristics are usually wrong
clock's timezone-guessing heuristics are usually wrong
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Winship
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 11:44 EDT by Dan Winship
Modified: 2008-10-14 11:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 11:05:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2008-03-27 11:44:25 EDT
If you create a location for Atlanta in the clock applet (eg, North America ->
US -> Georgia -> Atlanta -> Hartsfield Airport), the clock guesses
"America/Kentucky/Monticello" for the time zone, rather than the correct
"America/New York".

It looks like it's picking the time zone that is centered on the point closest
to the selected location. Unfortunately, most cities in the eastern US are
closer to one of the goofy microtimezones in Indiana or Kentucky than they are
to New York or Chicago, where their real timezone is "headquartered". And while
there probably *are* people in Miami who operate on the "America/Havana" time
zone, it's probably not a good first guess. :-)

If we don't actually have information about the geographical extent of the
timezones, we should probably just avoid guessing completely.
Comment 1 Matthias Clasen 2008-03-27 21:25:03 EDT
Yes, this could be improved. For large parts of the world, we can probably get
by simply by using the country information that is available in the weather
locations database.
Comment 2 Matthias Clasen 2008-04-01 13:32:40 EDT
Upstream bug where this issue is being worked on:
http://bugzilla.gnome.org/show_bug.cgi?id=519823
Comment 3 Dan Winship 2008-04-04 15:26:17 EDT
To fix this, we need:

http://bugzilla.gnome.org/show_bug.cgi?id=526015 (libgweather)
move gweather-xml parsing code to libgweather

http://bugzilla.gnome.org/show_bug.cgi?id=526216 (gnome-applets)
move gweather-xml parsing code to libgweather

http://bugzilla.gnome.org/show_bug.cgi?id=525451 (libgweather)
add iso 3166 codes (and timezone hints)

http://bugzilla.gnome.org/show_bug.cgi?id=519823 (gnome-panel)
Cities associated with wrong timezone

and we should also take:

http://bugzilla.gnome.org/show_bug.cgi?id=525761 (libgweather)
"Louisiana" consistently misspelled as "Lousiana"

Comment 4 Bug Zapper 2008-05-14 04:19:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Dan Winship 2008-10-14 11:05:04 EDT
this was actually fixed for F9, but never got closed

Note You need to log in before you can comment on or make changes to this bug.