Bug 439236 - rt2x00 does not establish wireless connection.
rt2x00 does not establish wireless connection.
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-27 13:12 EDT by Daniel Senderowicz
Modified: 2008-07-28 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-07-28 13:56:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
outputs of different commands. (82.24 KB, application/octet-stream)
2008-05-01 15:58 EDT, Daniel Senderowicz
no flags Details

  None (edit)
Description Daniel Senderowicz 2008-03-27 13:12:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)

Description of problem:
I have a PCI wireless card RaLink RT2600 802.1. With kernels newer than it does not connect at all. It connects OK with that kernel. However, even with it won't use the static address of the machine properly setup, it will always go the DHCP to get an IP number.

Version-Release number of selected component (if applicable):
subsequent to kernel-

How reproducible:

Steps to Reproduce:
1. After reboot, just check connection with the Network Manager and it says something like "Wireless Network Disconnected"

Actual Results:
No wireless connection.

Expected Results:
It should have established a connection to the present wireless network.

Additional info:
Comment 1 John W. Linville 2008-03-28 09:26:37 EDT
What is the latest kernel you have tried?
Comment 2 Daniel Senderowicz 2008-03-28 12:29:34 EDT
The latest I've tried was
Comment 3 John W. Linville 2008-04-08 15:49:52 EDT
Please try -- many rt2x00 users have reported success with it:


Does that help?
Comment 4 Daniel Senderowicz 2008-04-21 17:51:51 EDT
No, it's still deaf and mute. The worst part is that when I installed that
kernel, it erased the one that was working, so I have to figure out how to get
it back.
Comment 5 John W. Linville 2008-04-22 13:12:35 EDT
Please attach the contents of /var/log/messages after a failed connection.  
Also attach the output of running 'iwconfig' and 'lspci -n'...thanks!
Comment 6 Daniel Senderowicz 2008-05-01 15:58:50 EDT
Created attachment 304342 [details]
outputs of different commands.
Comment 7 John W. Linville 2008-07-08 16:06:59 EDT
Do you continue to experience problems with current kernels?
Comment 8 Daniel Senderowicz 2008-07-08 17:58:28 EDT
The latest kernel I downloaded was and is still deaf and mute. The
one that works is the old . As a reminder, even with the latter,
the IP is not what I set, it always goes to auto (dhcp). Thanks,

Comment 9 Daniel Senderowicz 2008-07-19 17:23:46 EDT
Last night I updated the system, that included Now it is able
to talk and hear through the wireless card. However the other problem still
remains. It assigns a random IP number, ala DHCP, although I have the LAN
configured as a fixed IP number. Or there is something else that keeps the
system from using the IP I gave it?


Comment 10 John W. Linville 2008-07-28 13:56:35 EDT
It sounds like either you are enabling NetworkManager or have not properly
configured the network in system-config-network.  In either case, this does not
sound like a kernel issue any longer.  I'm going to close this one -- you should
open a new bug if system-config-network is not working properly...thanks!
Comment 11 Daniel Senderowicz 2008-07-28 23:13:46 EDT
Hi John,

Yes, that was the problem. I just stopped Network Manager and it gives the right
IP. Thanks for all your help.



Note You need to log in before you can comment on or make changes to this bug.