Bug 439242 - fstab network mounts fail due to late network startup
fstab network mounts fail due to late network startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-27 13:31 EDT by Clyde E. Kunkel
Modified: 2014-03-16 23:13 EDT (History)
4 users (show)

See Also:
Fixed In Version: 8.68-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 11:45:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2008-03-27 13:31:32 EDT
Description of problem:
Network mounts (CIFS) fail since fstab entries mounted before network
initialization is complete

Version-Release number of selected component (if applicable):
upstart-0.3.9-13.fc9.i386

How reproducible:
every boot

Steps to Reproduce:
1. boot system
2.
3.
  
Actual results:
fstab cifs file systems not mounted. Have to manually mount -a after system is up.

Expected results:
fstab cifs file systems normally mounted during upstart transactions

Additional info:
dmesg output:
IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk>
ip6_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
 CIFS VFS: Error connecting to IPv4 socket. Aborting operation
 CIFS VFS: cifs_mount failed w/return code = -101
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
sky2 eth0: enabling interface
ADDRCONF(NETDEV_UP): eth0: link is not ready
sky2 eth0: Link is up at 1000 Mbps, full duplex, flow control both
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
eth0: no IPv6 routers present
Comment 1 Bill Nottingham 2008-03-27 13:38:02 EDT
This is not really an upstart bug, this is a netfs/NetworkManager interaction
problem.
Comment 2 Clyde E. Kunkel 2008-03-27 14:17:10 EDT
Disaabled network manager service, enabled network service and problem is
resolved.  Will let Mr. Nottingham assign properly.  Thanks for pointing out
real issue.
Comment 3 Bill Nottingham 2008-04-04 11:45:12 EDT
There's a hack fix for this in initscripts-8.68-1 - it enables netfs to be run
as a NetworkManagerDispatcher service.
Comment 4 Clyde E. Kunkel 2008-04-04 14:25:57 EDT
Network service has to be enabled for this to work.  Is that correct?  If not,
then the hack did not work for me.
Comment 5 Bill Nottingham 2008-04-04 14:33:19 EDT
No. It will re-run the netfs scripts whenever NM gets a working connection.
(You'll still get a 'FAILED' on startup from netfs ; that part hasn't been fixed
yet.)
Comment 6 Clyde E. Kunkel 2008-04-04 15:12:01 EDT
Ok, then shouldn't this bug be reopened since network mounts in fstab fail, but
not a blocker since a workaround (at least for me, I don't know about other
cases) exists?  Thanks and regards....
Comment 7 Bill Nottingham 2008-04-04 15:23:28 EDT
They shouldn't fail, they should work as soon as the network is available.
Comment 8 Clyde E. Kunkel 2008-04-04 16:42:03 EDT
True, they will come up, but they aren't automatically mounted with the other 
devices in fstab.  You have to remember to do a manual mount -a after your 
desktop or tty session is available.  It is that reason that made me wonder if 
the bz should be left open but not as a blocker.
Comment 9 Bill Nottingham 2008-04-04 20:33:11 EDT
I think we're talking past each other. You should *not* have to manually mount
anything with the fixes in 8.68-1.
Comment 10 Clyde E. Kunkel 2008-04-05 00:09:48 EDT
My bad....I had assumed that since I updated rawhide this afternoon that I had
the new initscripts.  Not true.  Got it from koji and now all is well.  Sorry
for all the noise.

Note You need to log in before you can comment on or make changes to this bug.