Bug 439270 - failure to select /boot terminates install
failure to select /boot terminates install
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Chris Lumens
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 15:53 EDT by Amy Griffis
Modified: 2008-05-21 11:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amy Griffis 2008-03-27 15:53:53 EDT
Description of problem:
If the user fails to setup a /boot mount point before leaving
the Create Custom Layout screen, the installation terminates
with an exception.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. for partitions, choose Create Custom Layout
2. setup the / mount point
3. do not setup a /boot mount point
4. choose [OK]
  
Actual results:

Anaconda gives the following traceback:

+--------------+ Exception Occurred +--------------+ 
|                                                  | 
| Traceback (most recent call first):            ^ |
|   File "/usr/lib/anaconda/fsset.py", line      # | 
| 2986, in getDiskPart                           : | 
|     if dev[-2] in string.digits:               : | 
|   File "/usr/lib/anaconda/partitions.py",      : | 
| line 867, in sanityCheckAllRequests            : | 
|     (dev, num) = fsset.getDiskPart(br.device)  : | 
|   File                                         : | 
| "/usr/lib/anaconda/textw/partition_text.py",   : | 
| line 1489, in __call__                         : |                           
  |     (errors, warnings) =                       : |
| self.partitions.sanityCheckAllRequests(self.d  v | 
|                                                  | 
|         +----+                +-------+          | 
|         | OK |                | Debug |          | 
|         +----+                +-------+          | 
|                                                  | 
|                                                  | 
+--------------------------------------------------+ 

Expected results:
Anaconda should allow the user to correct the problem and
continue with the install.

Additional info:
Comment 1 Chris Lumens 2008-03-27 20:45:49 EDT
Can you please attach the complete traceback to this bug report?  You can find
this in /tmp/anacdump.txt.
Comment 4 Amy Griffis 2008-03-28 17:12:09 EDT
Is there a way to get that information from the debugger?  The install fails
before it has a chance to format the root partition.

Here's a bit more seen after choosing [Debug].

 Traceback (most recent call first):
  File "/usr/lib/anaconda/fsset.py", line 2986, in getDiskPart
    if dev[-2] in string.digits:
  File "/usr/lib/anaconda/partitions.py", line 867, in sanityCheckAllRequests
    (dev, num) = fsset.getDiskPart(br.device)
  File "/usr/lib/anaconda/textw/partition_text.py", line 1489, in __call__
    (errors, warnings) = self.partitions.sanityCheckAllRequests(self.diskset)
  File "/usr/lib/anaconda/text.py", line 565, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 982, in ?
    anaconda.intf.run(anaconda)
IndexError: string index out of range
Comment 5 Amy Griffis 2008-03-28 17:37:01 EDT
I don't know this code, but do you need to sanity check either bootreqs or
br.device before calling fsset.getDiskPart() at partitions.py: 867?
Comment 6 Chris Lumens 2008-03-31 10:05:51 EDT
There is a complete traceback report in /tmp/anacdump.txt that anaconda also
prompts you to save to a remote system when the exception occurs.  This file
contains a full dump of the state of internal anaconda variables, so we can see
things like what dev was when it tried to subscript it (though I'm guessing it
was blank or perhaps None) and other things like that.
Comment 7 Chris Lumens 2008-04-01 11:56:34 EDT
Okay, I see what's going on here and have a patch that fixes this issue.
Comment 8 Amy Griffis 2008-04-01 12:11:57 EDT
Okay good, because I don't get the prompt to save off the dump file (maybe too
early in the install?) 
Comment 10 James Laska 2008-04-01 13:35:57 EDT
VERIFIED using snap#3 and http://people.redhat.com/clumens/439270.img

* Tested removing /boot and proceeding with / as a logical volume (error dialog
properly displayed)
* Tested removing /boot and proceeding with / as ext3
Comment 12 Chris Lumens 2008-04-01 14:44:34 EDT
This will be fixed in anaconda-11.1.2.111.
Comment 16 errata-xmlrpc 2008-05-21 11:33:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.