Bug 439289 - Occasional spontaneous/instantaneous reboot scrolling in Firefox
Occasional spontaneous/instantaneous reboot scrolling in Firefox
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 17:55 EDT by Chris Hubick
Modified: 2008-03-29 02:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 02:43:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log using xorg.conf (45.00 KB, text/plain)
2008-03-29 00:39 EDT, Chris Hubick
no flags Details
X log with no xorg.conf (48.37 KB, text/plain)
2008-03-29 00:40 EDT, Chris Hubick
no flags Details

  None (edit)
Description Chris Hubick 2008-03-27 17:55:00 EDT
While using Firefox, my computer likes to occasionally spontaneously and
instantaneously reboot - no warnings, nothing - browsing one second, POST screen
the next. Notably (?), my RAID 1 (non-root FS) does not do a rebuild on startup
(does this imply a kernel panic or rule out hardware issues?).

If I continue to return to the page I was viewing (Firefox offers to restore the
session), it would happen again and again - maybe not instantly, but usually if
I scroll the page at all.  It took me some time to isolate any apparent
commonality among the pages causing this:  They all seem to contain fairly large
images which are displayed scaled down in the web page.  Viewing those same
images full size causes no problems.

I have an Intel DQ965GF motherboard (
http://www.intel.com/products/motherboard/DQ965GF/ ) and a Core 2 Duo with 4GB
RAM, using the onboard Intel 965 video via a DVO/DVI card, running Fedora 8 with
all patches applied, in pure x86_64 mode (all i?86 packages removed).

I'm not sure what exactly to file this against, but I'm gonna guess at the i810
driver for starters (knowing Firefox has a close relationship with the X server,
and that with the Kernel).  Thanks for any clues or assistance you may provide! :)
Comment 1 Matěj Cepl 2008-03-28 20:20:23 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

Which URL it is? Do you have some other suggestions how we could reproduce this
problem on our computers?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Chris Hubick 2008-03-29 00:39:54 EDT
Created attachment 299562 [details]
X log using xorg.conf
Comment 3 Chris Hubick 2008-03-29 00:40:29 EDT
Created attachment 299563 [details]
X log with no xorg.conf
Comment 4 Chris Hubick 2008-03-29 00:48:29 EDT
Well, the last time I reproduced this bug, I was sending a message to my friend
on Facebook, and sent a picture of my motorcycle which I found on the net:

http://www.totalmotorcycle.com/photos/2005models/2005-Honda-919.jpg

So, hopefully you have Facebook? :)  Go compose a message to yourself... enter a
bunch of lines of "test" or whatever to make it so you can scroll, then paste
that URL in and send it.  Facebook should automatically include a "thumbnail"
(scaled down reference) to the image in the message.  If I do this, and scroll
up and down in the message for about a minute... poof!

I had it crash almost instantly the first time I sent the message to my
friend... but this time doing it to myself, I had to scroll for a whole minute,
long enough that I almost thought it wasn't reproduceable.  I wonder if it's
because the computer had just been restarted after the last crash, and the
browser was fresh, and the problem is some kind of video memory leak or
something that takes time to build up.

Let me know if there is anything else I can do! :)
Comment 5 Chris Hubick 2008-03-29 02:43:58 EDT
So, it just occurred to me (duh) that I had components for a second box which is
basically identical to this one (which I'm gonna build a HTPC/PVR out of)... so
I just hooked it up and boot the Fedora 8 Live CD on that, and I can't reproduce
this :(  This makes me think maybe this is a hardware problem (bad ram in the
AGP aperature maybe?).

I'm gonna close this, and will reopen if I can reproduce on 2 machines.  Sorry
for the bother.

Note You need to log in before you can comment on or make changes to this bug.